Home button sticks

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Love, Jun 5, 2009.

  1. Love macrumors 68000

    Love

    Joined:
    Jan 20, 2007
    Location:
    Just southeast of Northwestshire
    #1
    Well, the iPhone saga continues :mad:

    Today, I noticed that my home button sticks. Not the physical button, but the button under the physical button that's on the logic board..

    I pulled out my iPhone and I used the phone app, but when I tried to get out, it kept taking me to "favorites" and not letting me get rid of it.

    Then, as I pressed down on the sleepwake button to try to get it to reboot, the slider did not pop up, it just rebooted. To get it off the Apple logo screen, I had to press the home button quite hard, then it returned to normal.

    A couple more times today I've had this problem. It's starting to bother me. Should I bother replacing my iPhone? If you look in my post history, I used to have a black 8GB iPhone, but Apple decided to make my 5th replacement iPhone a 16GB model, because I've dealt with enough of Apple products and their poor quality (although most of my recent products (MB, iMac) have been quite good).

    Should I even make a fuss over this? It's kind of sad to have to be considering buying backup phones because Apple doesn't give them out... this iPhone was delivered on May 5th... one month today. This is just about the longest I've had one iPhone.
     
  2. lignsligns macrumors member

    Joined:
    Jun 3, 2009
    #2
    That has happened to me too several times but not lately. I just sways reboot and it stops. Unless it's a constant thing for you, I woud worry too much. Or just get the new iPhone coming out (maybe even see if you can upgrade for free) :D
     
  3. Love thread starter macrumors 68000

    Love

    Joined:
    Jan 20, 2007
    Location:
    Just southeast of Northwestshire
    #3
    It's kind of odd, sometimes I'll pull out my iPhone and it'll be sitting there with the Favorite's screen open. It's irritating because it's been killing the battery.
    Still unsure if I should bother with fixing this...
     

Share This Page