Home File Server using macbook/G-Raid

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Ahoora, Mar 27, 2014.

  1. Ahoora macrumors newbie

    Joined:
    Mar 27, 2014
    #1
    Hi folks .
    Basically I am looking for good suggestion / best solution to setup a Home File Server using my 2008 macbook 13'' which is still in good working shape with 8GB Ram and 250 GB HD , but I don't want to move it around , it is gonna stay static close and connected to my 4TB G-Raid external Drive , I also have a super hub wifi which can not connected directly to USB or Firewire drives so it needs a Network Attach Storage device to control and run the Hard Drive
    in other hand my main machine is my new Macbook Pro 15'' which I would like to work while using my G-Raid hard drive home as backup and file server drive through network, just to mention that the home super hub wifi is really super fast and is fibber optic base.
    Please any advise or suggestion what to do best with these to set up a good and reliable home file server so then I would not need to connect my MacBook pro every time to G-Raid drive whenever I want to use heavy files or back up my system , as I don't use the old macbook anymore it can be used as Network Attach Storage controller device to the hard drive , right? but it is not USB3 , it has only USB2 port and that is far slow for the G-Raid , so what would be the best option in your opinion?

    cheers, Ahoora
     
  2. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #2
    It should be not problem to do with what you have. I did it for a few years with a older macbook pro. Just set the "server" macbook pro up and connect what ever drives you need and share them via the sharing preference pane. You may need to add a guest user for you other macbook or use the same user name when you log in. If you wanted wireless time machine backups for the newer macbook you can get mavericks server for $19. Don't forget to set you servermac not to sleep or you will not be able to access it.
     

Share This Page