Home folder permissions

Discussion in 'macOS' started by jowie, Jun 25, 2010.

  1. jowie macrumors 6502a

    Jun 9, 2004
    London ish
    Hi all,

    I was wondering if you could help me. I am running as a user on a shared machine, and have created some folders in the root of my home folder. However, when other people use the machine under their logins, they get read access to those files. I assumed that all files within the Home folder were hidden from view.

    Is there any way I can change my Home folder permissions so nobody can see stuff in my folders? If I change it, will it mean people can't access my Public folder and Drop Box?


  2. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
  3. Hal Itosis macrumors 6502a

    Hal Itosis

    Feb 20, 2010
    By default, our home folder plus Public and Sites allow read access to all (whereas the other default Apple directories do not).
    cd ~ && stat -f '%Sp  %N' . *
    drwxr-xr-x  .
    drwx------  Desktop
    drwx------  Documents
    drwx------  Downloads
    drwx------  Library
    drwx------  Movies
    drwx------  Music
    drwx------  Pictures
    drwxr-xr-x  Public
    drwxr-xr-x  Sites
    [the first item (named ".") is our home].

    When we create a new folder there, it also grants group and world read-access (because of something called a umask). To secure newly-created folders, we would need to remove that access... and using a Finder info window (as spinnerlys showed) is probably the easiest method for most users.

    So —to deny access to these new folders while continuing to allow access to the Public folder —don't change the setting on the home folder. Rather, just tweak those new folders themselves.
  4. jowie thread starter macrumors 6502a

    Jun 9, 2004
    London ish
    Thanks! What great, in-depth replies! :)

    I almost feel guilty now to say that I'm going to keep it as it is... I'd never realised that the Home folder was read-only accessible to other users, I actually thought it was an error on this machine!

    It was mainly because I have installed Dropbox on here, and Dropbox puts their folder at the user root... So I have just removed public access to that folder and will make sure that any other non-public files I keep on this machine are in one of the default folders, or just add one of my own (and change the permissions, of course!)

    You learn something new every day... Thanks!


Share This Page