HomeKit "Home hub not connected" - why?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by Macwick, Feb 28, 2018.

  1. Macwick macrumors 6502

    Joined:
    Dec 9, 2008
    #1
    I have been using HomeKit for months now with no issues. I have four Apple TVs (and now a HomePod) serving as 'hubs'. I have multiple scheduled automation tasks that worked fine.

    Recently, however, the automation tasks are not running, and underneath each automation task I see the message 'Home Hub Not Connected'.

    When I look at the list of hubs (under Home settings), all 5 of them are listed in Standby.

    I've tried rebooting and upgrading all ATVs to latest release but still no luck.

    Anyone else have this issue?
     

    Attached Files:

  2. Macwick thread starter macrumors 6502

    Joined:
    Dec 9, 2008
    #2
    *bump* this is still happening to me constantly. Has *anyone* else had this problem? I turned off beta updates for my ATVs and iOS devices, so they're all running the latest released version of iOS/tvOS.
     
  3. robnbill macrumors member

    Joined:
    Jul 5, 2007
    Location:
    Northern VA - Fairfax Area
    #3
    We have two ATV 4K's plus a HomePod. The HomePod is connected and the ATV's are in standby. we have not run into this problem.

    What I would try if I ran into this is to unplug all the devices incl. the HomePod - then start out by plugging the HomePod in first and see if it connects. If it works, plug in the ATV's. Then, see if it stays.

    It sounds like the HomePod is occasionally connected? I assume they are all on the same local network - no subnets. I also assume you have two-factor authentication turned on. Can't think of anything else.
     
  4. Macwick thread starter macrumors 6502

    Joined:
    Dec 9, 2008
    #4
    Update - logging out and back in to iCloud on the Apple TVs seems to fix the problem. For a while, one of the ATVs shows 'Connected'. But after a couple of hours all the hubs are in 'Standby', and none of the automation works. So frustrating.
     
  5. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #5
    Make a note of which one is listed as connected. The next time the problem occurs again disable home for that one. Then see if everything continues to work. Basically narrow down the problem, one device should remain connected and if there is an issue another one should take its place however I’ve found “switch” to not always be reliable.
     
  6. Macwick thread starter macrumors 6502

    Joined:
    Dec 9, 2008
    #6
    UPDATE: I think I fixed it (in case anyone else has this problem).

    I set the 'Sleep After' to 'Never' on one of my Apple TVs. I then logged out and back into iCloud from that ATV. It has shown 'Connected' ever since. I suppose I could disable sleep on the others but it probably doesn't matter at this point.

    This is still obviously a bug, because even when all the ATVs go to sleep it doesn't 'promote' the HomePod to be the active hub.
     
  7. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #7
    Post back if it happens again. I have both of my Apple TVs set to sleep and its never been a problem. Although ever since I got the HomePod that is always the device it defaults too as the connected device and that doesn't have a sleep option.
     
  8. DNichter macrumors G3

    DNichter

    Joined:
    Apr 27, 2015
    Location:
    Philadelphia, PA
    #8
    Having the same issue, but only on my girlfriends iPhone. I can't figure out why it works fine for me, but not for her.
     

Share This Page

7 February 28, 2018