Home Network Set-Up Assistance Please!

Discussion in 'Apple TV and Home Theater' started by jezzar1, Dec 26, 2009.

  1. jezzar1 macrumors newbie

    Dec 26, 2009

    I would like some assistance in setting up my home network as I am not sure if my set-up is optimised.

    My current set-up is:

    Broadband home router (used as main network for each item below to join)

    All items below are connected to the main broadband hub wirelessly:

    2 x ATV
    1 x 1TB Time Capsule (Not wireless but ethernet to iMac)
    1 x 2TB Time Capsule
    1 x iMac
    1 x Macbook

    The idea is to use the 1TB Time Capsule for backing up my iMac. This seems to be working fine as is connected directly via ethernet.

    My 2TB Time Capsule holds all my movies and is currently streaming to my 2 ATV's. One in the lounge and one in the bedroom.

    I believe that this has all been set-up through my broadband wireless network and wanted to know if this was the best way to do it.

    I am not sure if I should be creating a new 'Home' network and then adding my broadband hub to that?

    Basically, I would like to be able to stream from one itunes movie library (2TB Time Capsule) to both ATV's using the 2TB Time Capsule as the media hard drive.

    Any help will be appreciated!
  2. tbayrgs macrumors 603


    Jul 5, 2009
    Sounds like it's working fine as is, not sure what, if any, problem you are having. I have iTunes on 2 different Macs pointing to the same media library on an External HDD and it streams just fine to 2 :apple:TVs.
  3. jezzar1 thread starter macrumors newbie

    Dec 26, 2009
    The connection is getting lost on my ATV upstairs and I keep having to re-join the network.
  4. rayward macrumors 68000

    Mar 13, 2007
    Houston, TX
    Check your power settings on the iMac. Even if your library is on the TC, your ATV is still pulling media from iTunes on your Mac, and the CPU has to be awake for it to do that. I kept losing my ATV connection, but it was because my Mac was sleeping.

    It seemed like the ATV was dropping off the network, and I "re-joined" my network trying to fix the problem many, many times before I had an epiphany about the power settings. They'd been reset when I upgraded to Snow Leopard, which meant that the Mac was sleeping after 3 hours of inactivity, and my iMac is too old for wake-on-network to work.

    I set my Mac's CPU to be always on, and Bingo! No more drop offs.
  5. jezzar1 thread starter macrumors newbie

    Dec 26, 2009

Share This Page