Home Sharing Issue

Discussion in 'Apple TV and Home Theater' started by evan.sams, May 2, 2014.

  1. evan.sams macrumors newbie

    Joined:
    May 11, 2012
    #1
    Hi All

    I realise that lots of people have posted on various forums on similar issues (I've been reading them!) but I can't seem to find my specific issue, and thus the fixes I've read haven't helped.

    Current Setup:
    Airport Extreme connected via ethernet in one room
    Mac Mini w/ external HD connected via ethernet in man cave (iTunes and library run from here)
    1x ATV3 connected via ethernet in family room
    1x ATV3 connected via ethernet in master bed room
    1x wireless printer connected via wifi in office
    1x VOIP phone connected via base station which is plugged into the router
    Mac Book Pro, 2x iPhone 5, iPad 2 and iPad mini all connected via wifi in various rooms as they walk around the house ...
    All iOS and software up to date, including iTunes

    Background:
    No issues with network, ATV3s or printer with above setup. A couple of days ago, I moved the router and phone base station from its original location to the man cave. The router is connected via ethernet and the Mac Mini and VOIP base station are both connected directly into the router.
    * internet still works fine
    * wifi works fine
    * Home sharing between Mac Mini and Mac Book Pro, iPhones, iPads all works
    * VOIP phone works fine
    * ATV3s can still access the internet

    Issue:
    * Home sharing between the Mac Mini and the ATV3s is down. iTunes on the Mac Mini says Home Sharing is on (and it works to the Mac Book Pro). But both ATV3s say to connect Home Sharing on my iTunes library
    * The printer cannot find the network either

    What have I tried:
    * restored ATV3 to factory settings and set them up again
    * disconnected router and reconnected it
    * read lots of forums talking about disabling iPV6 checkboxes, which confused me
    * checked firewalls to ensure they're off

    I'm confused as Home Sharing works for some devices but not others. Also the internet is obviously not the issue as all are connecting. And the ATV3s are on the correct network, as they're connected via ethernet.

    Am I missing something simple here? The only variable between the two setups is that I moved the router from one room to another. How could this change everything?

    Any help would be appreciated! :)

    Let me know if I haven't provided enough input.

    Cheers
     
  2. linds15 macrumors 6502a

    Joined:
    Oct 16, 2012
    Location:
    Great White North
    #2
    you've done some good troubleshooting already. how many devices do you have homesharing connected too? try turning it off a couple of them and see if it starts on the apple tv again. also, if you have a second apple id, try setting it up on the mac mini, then try connecting the atv3s using that login.
     
  3. evan.sams thread starter macrumors newbie

    Joined:
    May 11, 2012
    #3
    Thanks for the reply!

    We've only got the one apple id. And the only things trying to home share are the Mac Mini, the Mac Book Pro, and the ATV3s.

    The issue seems to be that the router isn't not seeing the ATV3s or the printer as devices and I'm not sure how to help it find them.

    Has anyone encountered a problem like this before? Surely there's a really simple fix?

    Cheers
     
  4. linds15 macrumors 6502a

    Joined:
    Oct 16, 2012
    Location:
    Great White North
    #4
    can you airplay from itunes to the ATVs? like play something in itunes and then manually go click the airplay button in itunes and pick the atv?
     
  5. evan.sams thread starter macrumors newbie

    Joined:
    May 11, 2012
    #5
    No, airplay isn't working either. When I go to Displays Preferences, it states "No Devices Detected" in the Airplay Display drop down menu.

    ----------

    I should add, yesterday, when trying to get it all to work, airplay reappeared for about 15 seconds and then disappeared. I have no idea what I did to get it to reappear in the first place, but cannot replicate ...
     
  6. CosmoFox macrumors regular

    Joined:
    Mar 10, 2014
    #6
    Backup your router config, and reset it. I'm not sure what else.
     
  7. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #7
    What are the IP addresses of all your HS devices? Those that work and those that don't?
     
  8. evan.sams thread starter macrumors newbie

    Joined:
    May 11, 2012
    #8
    The IP addresses is where I'm totally confused ...

    Looking in Airport Utility, the router has the following Internet settings:
    Connect via DHCP
    IBv4 Address: 124.171.172.165
    Subnet Mask: 255.255.254.0
    Router Address: 124.171.172.1
    DNS Servers: 203.0.178.191 and 203.215.29.191

    but then when I look in Network settings it says that the DHCP Range is 10.0.1.2 to 10.0.1.200 (shouldn't it be 124....?)

    Then when I go to the ATV3 it shows the following ethernet settings:
    IP Address: DHCP 124.148.139.49
    Subnet Mask: 255.255.254.0
    Router 124.148.138.1
    DNS 203.0.178.191

    So, with my limited IT skills, it looks like the IT and Routers are different? The strange thing is, both are connected via ethernet, so how could they possibly be different?

    The ATV3s are both set up to automatically detect ethernet settings. I tried manually inputting them to make them match, but that didn't work either.

    I'm still stumped how moving a router from one room to another could make all these settings change ...
     
  9. evan.sams thread starter macrumors newbie

    Joined:
    May 11, 2012
    #9
    All right I just had some progress!!

    If I turn the Router Mode from DHCP and NAT to Off (Bridge Mode) then Home Sharing works again!! However, while other devices can connect wirelessly to the network, none can access the internet unless via ethernet.

    Changing the Router Mode between the two seems to be the switch. How can I maintain Bridge Mode while still allowing wifi internet?

    So close!!!

    ----------

    Oh, I should note, when I'm in Bridge Mode and all devices lose wifi internet, my Mac Book Pro still is able to use the internet with no issues. That's the really strange thing!
     
  10. evan.sams thread starter macrumors newbie

    Joined:
    May 11, 2012
  11. Lord Hamsa macrumors 6502a

    Joined:
    Jul 16, 2013
    #11
    Maybe check the MacBook settings and make sure it isn't trying to share its network connection - this could cause essentially two routers on the network, which could create some of the network issues you describe.
     
  12. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #12
    Yep

    Your AppleTV's should have an IP address of 10.0.0.X and clearly they do not.

    You have something completely hosed in your router settings. Do you maybe have a double NAT situation going on? This is caused if your Cable/DSL modem doles out IP addresses as well as your Airport Extreme.

    What happens in a home, is that your modem (whether cable or DSL) has a "real" IP address so that it can get internet. Then your router creates "fake" IP addresses to share that single internet connection. In your case those fake IP addresses are 10.0.0.x.

    So what we need to know is what kind of modem are you using? Further, when you went to bridge mode, but all the rest of your wifi devices lost internet, did you refresh their IP addresses (easiest way is probably just to restart, but you can also do it in the Network preferences)?
     
  13. dpavid macrumors regular

    Joined:
    Feb 17, 2004
    Location:
    Mililani, Hawaii
    #13
    I have the same problem. Airport Extreme Router. All Macs are hard wired to the airport including the Apple TV3. ATV3 plays back any internet source fine, even loads iPhoto for screensaver but doesn't recognize the itunes libraries on Macs. Says to turn home sharing on and connect to the same account which they all are.

    I can however play itunes from a mac and select airplay to send it to the Apple TV. I just can't start a movie from the ATV3 from itunes.
     
  14. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #14
    What the two things people get confused with in networks is DHCP and how to deploy it in the home plus NAT (Network Address Translation).

    1. You should only have only 1 NAT sever in your home network so all your devices stay in the same subnet (for internal sharing).

    2. Home routers take one address and creates it's on internal network with Private IPs.

    So in Home networks you should have only one router doing NAT (usually nearest to the modem). So any other router doing NAT behind another router should have NAT turned off. In Apple routers they call that "Bridged Mode", that is what Apple calls turn off NAT.
     
  15. dpavid macrumors regular

    Joined:
    Feb 17, 2004
    Location:
    Mililani, Hawaii
    #15
    I only have one router from the modem but I do have multiple gigabit switches. They're all after the router. One at the TV for Audio receiver, TV, Cable Box, PS4 and Apple TV 3. Another upstairs for 3 more apple computers.
     
  16. has.marvel, May 17, 2014
    Last edited: May 18, 2014

    has.marvel macrumors member

    Joined:
    Jan 13, 2012
    #16
    Well, I am having a home sharing issue also but I think mine maybe different. I have been able to access my library just fine up until tonight. I went to access the computer from my ATV3 and it clocks for awhile and says it cannot find the library. I can find and access the library from my iPhone or iPad on the same network so I don't think it is the network and sharing is definitely on. I am current version of iTunes, 11.2.1. Not sure what else to try. It just suddenly went away. Powered off and on the AT3 just in case but that did not help. I can access the network and stream from Netflix just fine on the same ATV3. It is just home sharing that is failing.

    Thanks for ideas.

    UPDATE: I solved my problem. I disconnected the ATV from power for about a half hour. When it restarted, suddenly the library was there again. Not sure what made it go away but glad that it has returned.
     

Share This Page