Home Sharing, it takes forever to load the library

Discussion in 'iOS 7' started by hafr, Nov 5, 2013.

  1. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #1
    In iOS 6, loading the iTunes library via the Video app for instance took a long time, but you could see the progress and eventually it would load (although it would be messed up with wrong posters for instance). But with iOS 7, it takes even longer to load, and often it just stops loading as if there was nothing there.

    I've dis- and reconnected Home Sharing, made sure I have the latest versions of iTunes and iOS, reset settings... Does anyone have any tips and tricks for me to try?
     
  2. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #2
    Same for me.

    I've mentioned this in a different thread and I don't want to turn this into an iOS bashing thread but as you mentioned with iOS 6 you saw a "clock" or "radar screen" design where it showed the progress of the connection. You could see it stop or know about how much longer it would take. iOS7 now has a spinning circle that gives no feedback other than the screen is being redrawn. Sometimes it connects quickly, most of the time it takes a long time, and sometimes I sometimes close the app after I figure the circle is tired from spinning for no reason. :D

    I haven't found anything to speed it up so I'll keep an eye on this thread. Two days ago it connected after about two seconds and I almost fell out of my chair.

    Latest iTunes (11.1.2 IIRC) on Windows 7 x64.
     
  3. cipo macrumors member

    Joined:
    Nov 23, 2010
    Location:
    Stuttgart, Germany
    #3
    Unfortunately, this has been unusable for me for a very long time - it was only marginally better in iOS 6. Since then, I've gone through different wireless routers, iOS devices, iTunes versions, switched from Mac to Windows server ... makes no difference.

    I understand that my library is larger than average, but I am absolutely sure this is a software bug in the music / video apps. Why? Because the Remote app on those same devices has always been able to access and browse that same library instantly(!) and consistently, and I see no reason why this should be any less complex or involve fewer data being transferred, let alone explain the difference between sub-second access and 30 minutes.

    I just wish Apple's software engineers would talk more to each other. :(
     
  4. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #4
    A
    Same here any fixes since these posts?
     
  5. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #5
    Not for me. At least they returned the status circle so I know it's loading or not. I'd say my library takes about two minutes to load. I was going to buy a Mac Mini and get my library off Windows but at the last minute decided to not make another contribute to Apple's cash surplus.
     
  6. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #6
    I figured wonder if anything will change with iOS8 as well as Yosemite? It probably lies within iTunes though and we all know that's been updated countless times already:rolleyes:
     
  7. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #7
    Yeah... I always hope it will get better. Fortunately Apple TV doesn't suffer in the same way.
     

Share This Page