Home Sharing Library taking forever to load

Discussion in 'iPad Tips, Help and Troubleshooting' started by LeicaM8, Feb 20, 2013.

  1. LeicaM8 macrumors member

    LeicaM8

    Joined:
    Nov 29, 2012
    Location:
    West Michigan
    #1
    Hello,
    We're finally starting to use Home Sharing via wi-fi for the GF & I to access our content and while it's eventually streaming just fine, I do wonder:
    Is it Normal for the Video App to take a long time to load the HomeSharing Library?

    It's taking between 5 and 15 minutes to load and appears to get worse with each addition to our Video Library in iTunes. I'm accessing via an iPad3, she's on an iPad2, and the Library is on a MacPro running ML connected to the router via ethernet cable. Only traffic on the router is her and I's iPads.
    Thx in Advance,
    Richard in Michigan
     
  2. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #2
    I've noticed this as well with iOS 6 and I only have 25 movies and 155 TV shows in my current library. Sometimes it loads semi-fast while other times it's incredibly slow. I don't remember it being this slow with iOS 5.
     
  3. LeicaM8 thread starter macrumors member

    LeicaM8

    Joined:
    Nov 29, 2012
    Location:
    West Michigan
    #3
    I really do wonder what the issue is though.
    I've just started using it, but it is 'just' annoying enough to make me NOT want to use Home Sharing in spite of how appealing I find it to be.

    Hope it gets fixed soon.
    Maybe it's a feature Apple and/or content providers want to whither and die so folks use streaming video to sell ads, subscriptions, or run up Data Usage Charges!
    Sigh
    R. in Mi.
     
  4. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #4
    Not at all. Since Home Sharing requires you to be on the same network as your iTunes library, you can't access it from a cellular connection. On top of that, Home Sharing is for content you already own, so subscriptions and ads don't play a part here.

    I think it's just one of those things that got messed up with iOS 6 and I'd assume a fix is on the way. It's not like it's completely broken, it does still work.
     
  5. LeicaM8 thread starter macrumors member

    LeicaM8

    Joined:
    Nov 29, 2012
    Location:
    West Michigan
    #5
    Thx for the encouraging thoughts that Homesharing will eventually work well, someday, maybe soooooon! :D
    I think it really is the perfect thing for my GF and/or myself to easily access our content via our iPads. We have a vidbox on the TV, but not via wi-fi so network traffic is minimized. Old Fashioned Sneaker Net with Big USB HDs.
    Richard

     
  6. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #6
    Any luck with getting it to work since the OP? I'm in the same boat very frustrating. :(
     
  7. CEmajr macrumors 601

    Joined:
    Dec 18, 2012
    Location:
    Charlotte, NC
    #7
    Looks like it's still not fixed even in iOS 8. Since I bought an Apple TV I recently converted all my movies to MP4 and loaded them into iTunes. The Apple tv can access them rather quickly but now home sharing on the iPad ans iPhone is extremely slow, taking almost 15-20 minutes to load up the library.
     
  8. skyhawkmatthew macrumors member

    skyhawkmatthew

    Joined:
    Oct 1, 2007
    Location:
    Australia
    #8
    Yep, still broken. I have 1.5 TB of video in iTunes and I occasionally try loading home sharing on the iPad and always give up before it's even a quarter done 'loading'.
     
  9. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #9
    Inexcusable. :(
     
  10. Richdmoore macrumors 65816

    Richdmoore

    Joined:
    Jul 24, 2007
    Location:
    Troutdale, OR
    #10
    I have a large 3tb library, and while the apple tv 3 has no problems, it takes forever for the iPad as well. I keep hoping each IOS update changes this, but it still is very, very slow.
     
  11. smitt, Mar 15, 2015
    Last edited: Mar 15, 2015

    smitt macrumors newbie

    Joined:
    Mar 15, 2015
    #11
    It's been broken for me since iOS 6, which is why I went with Plex Media Server + Plex iOS app combination. Little to no initial buffer, plus the benefit of expansive format compatibility and remote WAN viewing.
     
  12. bergert macrumors regular

    Joined:
    Jun 24, 2008
    #12
    large library-HomeSharing hangs

    have about 250 movies bought on iTunes; plus about 5000 others (my VHS and DVD collection converted to MP4). Dedicated MacMini for iTunes.

    iPad mini and iPad and both are not able to connect. The circle (round progress bar) hangs at 50% - if I leave it there for an hour there is a error message. I have two aTV and both can connect without problems.

    iPad mini (1st Gen, iOS8.3) = cannot connect; hangs
    iPad (1st Gen, iOS 5.0.1) = cannot connect; hangs
    aTV (3rd Gen, iOS 7.0.1=latest same as iOS8.0.1) = no problems

    filed a bug report with apple (no reply as usual)
     
  13. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #13
    Happen to me too. It loaded very fast when I first got iPad Air 2 but now extremely slow with iOS 8.3 but re-signed in fixed it.
     
  14. syltrem macrumors newbie

    Joined:
    Feb 26, 2013
    #14
    Same thing here. IOS 8.4
    At first I thought it would be cool, as I just bought an Apple TV (actually to stream music to my HiFi system) but although the ATV has no problem loading the video library as other have said, it's very very very slow on the iPhone (around 5 minutesfor me).

    So far I only have about 50 videos in the library as Apple does not support MPEG-2 (most of my stuff is ripped DVDs). I don't feel like converting all to MP4 which is more lossy I read.
     
  15. JohnnyW2K1 macrumors member

    JohnnyW2K1

    Joined:
    Jan 27, 2016
    Location:
    London, UK
    #15
    Sorry for resurrecting an old thread. Google brought me here. I'm having the exact same issue. My Apple TV 3 is pretty quick at loading my home library, but for my iPad 3 it literally takes five minutes.

    How can this still be? Why hasn't it been fixed in all this time? :(
     

Share This Page