"Home Sharing? No Home Sharing."

Discussion in 'Apple TV and Home Theater' started by jonathanrobertb, Feb 4, 2011.

  1. jonathanrobertb macrumors newbie

    Feb 4, 2011
    Home Sharing is not working for me. After reading through these discussions, I'd say there's a chance it's not working for you either.

    What I've done for us, here, is compile a list of helpful trouble-shooting tips that I've copied and pasted from other users. Sadly, none of them have worked for me, but perhaps someone will come along and add that one item to the list that will solve my problem. I hope it helps you, and I will certainly report back when I get my problem resolved.

    As a reminder, this list is for folks who've already exhausted the obvious resources - like the Apple TV support page etc. - to no avail.

    My scenario: (it probably reads similar to yours, so you can skip this part if you want)Purchased the Apple TV last weekend. Setup was easy, connection to my itunes account and network was easy (running latest version of itunes. Able to access movies, internet, itunes account etc). My wife and I both have iphone 4s, and both can see the Apple TV and I can "airplay" from our iphones to the Apple TV. Remote app also works on both phones. This is what makes me think it's not a router issue, but rather an issue at the PC. I have two PCs, both running Windows 7. One houses my primary media library. Neither one of them can "see" the Apple TV, nor can the Apple TV "see" either of those libraries. Further, the PC's cannot see eachother. I spent about an hour and a half with Tech Support. My issue was escalated to "the engineers" and I am currently waiting on a response. I've tried each of the below strategies, but no dice. I am absolutely convinced that the trouble is with Windows 7 and the itunes/quicktime/bonjour Apple Software Package. On of my PCs is a netbook, and I have the ability to load and unload everything as needed to try to get this to work. Last night, I went through the complete Apple software package uninstall and reinstall and also uninstalled my AV (using AVG 2011 free). Disabled router firewall and windows firewall along with Windows defender. Still nothing.

    Troubleshooting Ideas/Tips:

    1. "...Then, last night I was trying to get it setup and working and when faced with the same issue I started digging around my Network Settings and changed "Configure IPv6" from "Off" to "Automatically" and like magic, instantly my iTunes Home Sharing showed up on the Apple TV."

    2. "...So I had to go into the firewall advanced security and tell Windows to allow iTunes to send and receive data."

    3. "Ok, I forgot one thing. In the homegroup settings I had to tell it to allow steaming with other devices on the network. this was in the Control Panel, Homegroup. After I saved the update I had to wait for a while till it processed the information before it became available. Hope this helps."

    4. "I remember having a similar problem, it turn out to be a problem with apples BONJOUR service, had to uninstall Bonjour and reinstall it, then turn Home Sharing back on to get it working."

    5. "...Anyway, after setting Norton to allow access to iTunes’ support program, called “Bonjour”, I now enjoy rock-solid Home Sharing performance. If you use Norton, open it, go to "settings", then "miscellaneous settings", then "program exclusions" (hard to find), then use the browser that pops up to find “Bonjour’s” executable program at C:\Program Files\Bonjour\mDNSResponder.exe. Click "Apply", then "OK", then exit. Restart iTunes, and Home Sharing from that computer should work."

    6. "Check Firewall Settings
    If you have a firewall enabled in your router or computer, make sure that the firewall is not blocking communication between your computers. Home Sharing uses TCP port 3689 and UDP port 5353 to communicate with other copies of iTunes.
    For Mac OS X 10.5 or later, you don't have to edit the port addresses, but make sure the firewall in Apple () menu > System Preferences > Security > Firewall are not set to:

    Block all incoming connections
    Allow only essential services
    If you use another operating system, firewall software, or hardware, check the documentation on how to open TCP port 3689 and UDP port 5353."

    7. "Enabling the photo sharing on one folder did the trick for me. Prior to that I upgraded to iTunes 10.1, disabled and re-enabled home sharing on the PC and the ATV2 and rebooted both."

    8. "Okay, i have had the same issue as many here: updated iTunes, sharing working on iPad and iPhone, but nothing on the appletv. Here's what fixed it for me: 1 open iTunes and confirm sharing settings in preferences. 2. Go back to the iTunes main panel and look for "shared" region of the left toolbar (where it has library, store, shared, and genius headings. For me, i had to click on shared, select "show" from the right of it, and then found a sub-item. I clicked on that, and had to input my password one more time, and finally confirmed I wanted sharing on. After that, the library showed up just fine."

    9. "iPhoto source under iTunes Advanced Menu -> Chose Photos to Share. Once I selected the iPhoto option then it worked."

    10. "...believe I have solved the problem and the problem was in my third party Virus Barrier which blocked internal addresses that demonstrated high activity. The problem was the ATV sending a "flood" of requests to download the library and the Virus Barrier software blocked the address as an intruder. I removed the 192.168.100.xxx address from the virus barrier "connection flood" blocked address, and all works just fine. Hope this solution pertains to others."

    11. "If I open iTunes and enable Home Sharing and authenticate, then "Home Sharing" appears in the Shared section of the left hand pane (same pane that lists Devices, Playlists, etc. If I then click "Done" on the main screen view this "Home Sharing" listing disappears and I can't see the library on the ATV2.
    However, if I don't click "Done" and carry one then all's well. I can move around iTunes and do all the normal stuff but as long as I don't close that Home Sharing screen view it works fine."

    12. "Problem solved. Go to iTunes preferences, and under "devices", uncheck the "Look for Remote Speakers connected with Airplay." This seems to confuse Apple TV in syncing with your Library, if you don't have Remote Speakers."

    13. "I followed the advice of posts here, and turned "Sleep" to "Never" and the ATV2 has worked without a hitch for the last week."

    14. "I'm posting this in case it's of use to anyone else. I was unable to get Home Sharing to work at all with my ATV2, I tried all of the suggestions on this thread and others. Eventually I gave up and phoned Apple. Plugging in the ATV straight into my PC solved the problem, but obviously wasn't a usable fix.
    Tracked the problem down to my router (Belkin Max). Seems it blocks port 5353 between LAN ports for some strange reason and worse still there's no way to change it. The only solution I could find was to replace the router (luckily at no cost as it was only 3 weeks old) for a linksys router and it all works fine now."

    15. "When I was troubleshooting my ATV2 problem, I turned my firewall completely off. I don't use my Mac's built in firewall. I use NetBarrier X5. NetBarrier also includes functionality called Antivandal. NBX5 allows you to set policies (Buffer Overflow Attacks, Intrusion Attempts, Ping Attacks, Ping Broadcasts, Port Scans and SYN Flooding). I have these policies turned on. When NBX5 detects a policy "violation" it automatically sends the "intruder" to a permanent stop list (at least that is how I have my system configured). Thus, those IP's are permanently blocked. The IP remains blocked even if you turn off the firewall. That was a troubleshooting oversight on my part. I actually ran into the same problem when I was setting up my first ATV a year ago (but I forgot about it - bummer for me). When I checked my stop list, I found two IP addresses that I allow for my home network. Voila."

    16. "I found a fix that was suggested in another thread that seems to have worked for me. If you disable the quality of service (QoS) protocol on your router it seems to connect with no problem."

    - That's it for now. I will try and keep an eye on this post and update when possible. Hopefully, I'll be able to post some good news sometime soon.
  2. RWinOR macrumors 6502

    Sep 11, 2010
    Greenest and wettest place in North America
    I also noticed as soon as I put an apple tv on my network my devices all reacted differently with the ITUNEs. Devices that once worked well no longer worked. I set Apple sharing only to find it was intermittent with my MacBook Pro. It was extremely stable with my wife's IMac. I did not go through all the steps you tried, but I did find the cause of my issues.

    I had a PS3 and had installed MediaLink to use DNLA sharing, when the PS3 died I purchased another Sony blueray and had to set up another DNLA Media server (I cannot remember the name) to share photos and the such. These DNLA servers would block the ITunes library from sharing after the computer went to sleep. If I rebooted all was well. as soon as the computer went to sleep ITunes stopped sharing. I removed/uninstalled all DNLA servers, and have not had a single issue with Itunes since then.

    I do not know if this is our problem but you might try uninstalling your DNLA media servers as a test.

    Best of Luck to you

Share This Page