Home sharing not working

Discussion in 'Apple TV and Home Theater' started by argo13, Mar 26, 2011.

  1. argo13 macrumors newbie

    Joined:
    Mar 26, 2011
    #1
    I cannot home share with my MBP and ATV 2. Home sharing is turned in iTunes and on the ATV, but none of my libraries appear on the ATV. The MBP is connected to my network wirelessly with a Belkin G router. I usually use a wired connection for the ATV 2, but I've tried it on the wifi setting as well. My libraries still do not appear in the Computers menu.

    Has anyone else had this problem? Do you know a solution?
     
  2. ISO:HELP macrumors regular

    ISO:HELP

    Joined:
    Oct 23, 2006
    #2
    not sure whats going on in your end..


    but when I see the "no share Error" I go to the smb setion of my mac book change the libary name and then change it back.

    fixed..

    hope that helps
     
  3. TricBox macrumors newbie

    Joined:
    Feb 3, 2008
    #3
    My APTV2 loses its connection. I just do a reboot and it's there. I didn't have this problem when I first hooked it up. I think it's a flaw in the latest iOS update since that is when the problem started to occur.
     
  4. ISO:HELP macrumors regular

    ISO:HELP

    Joined:
    Oct 23, 2006
    #4
    Ever since I JB'd my Iphone a few months ago I have been very weary of any updates....even of its for a video ad-on for xbmc...


    eh
     
  5. ksmith80209 macrumors 6502a

    Joined:
    Aug 15, 2007
    #5
    +1. I have to do reboots after the drives hooked to the home sharing-enabled Mac spin down.
     
  6. Cha macrumors regular

    Joined:
    May 1, 2010
    #6
    A few questions to the OP:
    - Are both the AppleTV and MBP connected to the same router? Or do you chain multiple routers in your network setup?
    - How many computers have "Home Sharing" enabled on the network? (There is a limit to 5)
    - Did you check to see if the "sharing" issues are still present if you disable the firewall on your MBP?
    - Can you telnet to your AppleTV IP on port 3689?

    Just throwing out some ideas. I have Home Sharing working on both my MBP and a Windows 7 machine with 2 ATV2...
     
  7. applemike68 macrumors regular

    Joined:
    Mar 18, 2011
    #7
    :apple:TV2 cannot find my computer as of today. Matter a fact when I turned it on my home videos were there but when I clicked, nothing...It says no videos, but clearly it worked this week or before the update. I'm going to try and reboot...but very annoying...
     
  8. argo13 thread starter macrumors newbie

    Joined:
    Mar 26, 2011
    #8
    For any of you who were scratching your head on this one, please know that it was me who was being stupid. I was logged in using my guest password. Thank you to everyone who tried to help.
     
  9. applemike68 macrumors regular

    Joined:
    Mar 18, 2011
    #9
    I fixed mine by just rebooting and it worked...
     
  10. ayzee macrumors 6502a

    ayzee

    Joined:
    Jun 12, 2008
    #10
    Been this problem for 2 days since I bought my apple tv. I enabled home sharing by going to the preferences menu in iTunes. Tried so many things but my library still wouldn't show on my atv2.

    I decided to read the apple help, and realised you have to activate hone sharing by going to the ADVANCED menu in iTunes, where you enter your login and enable home sharing.

    It then work straight away. Why apple have two different places in iTunes for hone sharing is beyond me. Not very user friendly at all
     

Share This Page