Home sharing + other rested info

Discussion in 'Mac Apps and Mac App Store' started by Tech198, Feb 14, 2012.

  1. Tech198, Feb 14, 2012
    Last edited: Feb 14, 2012

    Tech198 macrumors G5

    Mar 21, 2011
    Australia, Perth
    Has anyone noticed in iTunes when Home Sharing is enabled the "Allow incoming connections to iTunes.app" dialog constantly appears on every launch of iTunes, even though its listed in the Firewlal as "Allow incoming connections" ?

    I don't believe it did to 10.7.3, as I never used iTunes, till my mac was up-to-date, but I've been talking with Apple, and they couldn't solve it either.

    They first asked me to create a second user account and try from there. On launch from the "new admin" account, they asked me to launch iTunes from there and see it if the dialog still came up, which it did.

    I then decided, to remove the entry to System Preferences>> Security & Privacy, Firewall tab and Advanced, and click the "-" to remove it.

    On launch of iTunes it didn't pop, presumably coz it had to add it. but on repetitive launches of the iTunes, it popups up again. Having trashed the Library Prefs (moved to desktop temporarily) reboot of mac, the problem still continued. Turning "off" firewall seems the only thing that resolves this, but then your not protected, and I can't keep Home sharing off because I use it with Apple TV, thus the dialog.

    I assume doing a complete reinstall of Lion fresh or archive wouldn't help, but is there anything else I could try ? Or is it just an issue that needs a fix.

    On a totally unrelated issue, I also experienced an issue with multiple accounts.. After coping my Itunes Purchases over to the other user account, they fail to show up in iTunes. These are Mobile Applications I downloaded from iTunes and kept on my Mac...

    But after copying the iTunes/Media folder to Shared, then to the other Music/Itunes Library. Nothing appears under the Apps column (hidden by default, but enabled under Preferences from iTunes) .

    Even though the physical folder is moved or copied from the first account to the second, is there any way to have iTunes recognise this ?

    Attached Files:

  2. robgendreau macrumors 68040

    Jul 13, 2008
    You say you are "unprotected" if you turn off your Mac's firewall. But if you have a router that has an active firewall you probably don't need the one on your Mac unless you have unscrupulous folks sharing the same local network ;)

  3. Tech198 thread starter macrumors G5

    Mar 21, 2011
    Australia, Perth

    yes..i'm a a home network... (about 5 PC's on my LAN)

    plus, for extra security and peace of mind.

Share This Page