Home sharing problem

Discussion in 'iPad' started by mizvalorie, Mar 9, 2011.

  1. mizvalorie macrumors regular

    Mar 22, 2010
    I am trying to get home sharing on my iPad. I have checked everything in itunes and sharing is on. ID and password are entered in the iPad...but I still have nothing. Can anyone help me? I've googled and can't see what else to do?

    I also did a hard reset.
  2. al256 macrumors 6502a


    Jun 7, 2001
    Check the firewall on your computer. Make sure it's not blocking all ports.
  3. djransom macrumors 68040


    May 14, 2008
    Make sure the PC or Mac is authorized to share. I ran in to this problem as well.
  4. mizvalorie thread starter macrumors regular

    Mar 22, 2010
    I've done both.

    Firewall says itunes is allowed incoming connections.

    Authorized too.
  5. mizvalorie thread starter macrumors regular

    Mar 22, 2010
    thanks guys but I did all that before posting...

    I am just not sure what else to try.
  6. DavieBoy macrumors 6502


    Jan 8, 2009
    New Jersey
    I did everything right but it still took forever for my library to pop up.
  7. rkulpajr macrumors member


    Sep 27, 2007
    Columbus, Ohio
    Double check to make sure it is not there...I thought the same thing and then found it at the top of the list of playlists.

    see attached photo. I drew an orange arrow...

    if you select this button you can have your library load...

    Attached Files:

  8. mizvalorie thread starter macrumors regular

    Mar 22, 2010
    I do not have that symbol there. I have no music currently on the iPad so its not hard to miss much. There is nothing there and I even waited about a day to see if maybe it was just taking a long time or something. Nothing still.

    Do you think I should contact apple about this and see if they can help?

    Thanks for the help so far.
  9. seajay96, Mar 11, 2011
    Last edited: Mar 11, 2011

    seajay96 macrumors 6502

    Jun 26, 2010
    Just to ask the stupid question, where did you enter your iTunes account info on your iPad? Should be under iPod settings. Literally within 2 secs of doing this, the home icon and my shared library showed up on my iPad.

    Edit: And to ask another dumb question...are you actually on the same wifi network?

    If you've already done everything mentioned above, I'd give Apple a call.
  10. mizvalorie thread starter macrumors regular

    Mar 22, 2010
    Yep all of that...Alright I'll call apple. ugh. I hate technical support. Thanks though!
  11. trozau macrumors regular


    Jul 4, 2010
    Appleland, USA
    Do you have iTunes 10.2.1? If not, I believe you have to update up to that version. :)
  12. drarrex7 macrumors newbie

    Aug 21, 2008
    It's probably too late, but I ran into this problem today as I tried to use home sharing on my iPad for the first time. After tinkering with it for a while, I found a solution.

    In iTunes, click the Advanced menu and choose "Turn off home sharing." Then turn it back on by clicking the Advanced menu again and choosing "Turn on home sharing." It will prompt you for your Apple ID password, and then you're done.

    In my case, immediately after doing this, it started working on my iPad. Hope this helps (if you haven't already gotten it going.)
  13. duncyboy macrumors 6502a

    Feb 5, 2008
    I've been faffing with this all evening and have found a solution.

    I've just bought an Airport Express for my WiFi and am using my router for purely wired duties INCLUDING my iMac. So my iMac and AE are connected to the router, my iPad and iPhone connect to the AE.

    I've just enabled Airport on my iMac and everything works fine now! Remote and Home Sharing- so make sure you're LITERALLY connected to the same network :)
  14. PatriotInvasion macrumors 68000


    Jul 18, 2010
    Boston, MA
    I'm able to find my Home Share, but not all videos in my iTunes Library are visible. If it was purchased in the iTunes Store, its there...if i created and imported it myself, its not there. Any idea why?

Share This Page