Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Itinj24

Contributor
Original poster
Nov 8, 2017
3,194
1,574
New York
Updated my HomePods and Apple TV’s today. Don’t see an option anywhere to enable this, unless I missed something. Help, anyone?
 

firewire9000

macrumors 6502
Sep 15, 2015
444
636
I actually don’t know what exactly is it. The release notes says something that you can use the HomePods as stereo and home theater, like the first option was since almost the beginning. I don’t get it.
 

Itinj24

Contributor
Original poster
Nov 8, 2017
3,194
1,574
New York
I actually don’t know what exactly is it. The release notes says something that you can use the HomePods as stereo and home theater, like the first option was since almost the beginning. I don’t get it.
Yeah it’s supposed to get Dolby Atmos with this update but I don’t see where to enable it. There was a pop up to enable the HomePod as the default audio source. After scouring the Internet, I’m starting to think enabling it as the default audio source automatically enables Dolby Atmos. I may be wrong though. So confused.
 
  • Like
Reactions: profets and B/D

B/D

macrumors 65816
Mar 30, 2016
1,224
893
It´s all automatic.

t turns out that Auto is the only thing that you are suppose to see in the apple tv audio menu when the homepods are connected to the ATV. No immmersive audio option and no Atmos badge.

Just make sure that the Apple TV have change format set off and that the default sound format is set to auto and you are good to go.

In fact, there is no need to have the homepods set up as the default audio output for the Apple TV for the Home Theater sound to work. Just select them normally as the output via the control center of the Apple TV.

As long as they both are (the Homepods and the Apple TV), in the same room in the home app, and they are both updated to 14.2, the Home Theater audio processing will kick in automatically when they detect a 5.1, 7.1 or Atmos track .

In fact, selecting the homepods as the default audio output for the Apple TV kills my Apple TV wifi speeds, and makes them make popping and crackling noises when browsing the apple TV menus.

But it turns out that is not necessary for the home theatre sound to work. Just select the Hompeods from the Apple TV control center and you are good to go. When you finish, select back your internal tv speakers.

Much better sounds in movies and TV Shows (Atmos and regular 5.1), than before. Dialogue is clear and robust, soundstage is full and enveloping, and there are plenty of directional sound going on. Very impressive.

I have a homepod stereo pair, BTW.
 

hobspain

macrumors regular
Mar 29, 2010
127
116
But it turns out that is not necessary for the home theatre sound to work. Just select the Hompeods from the Apple TV control center and you are good to go. When you finish, select back your internal tv speakers.

This is not correct. You do have to set the HomePods as the default speaker. Turning it off and selecting it from the Control Center you don’t get the Atmos sound. This is very noticeable.

And, well, Apple tells you so anyway
 

B/D

macrumors 65816
Mar 30, 2016
1,224
893
This is not correct. You do have to set the HomePods as the default speaker. Turning it off and selecting it from the Control Center you don’t get the Atmos sound. This is very noticeable.

And, well, Apple tells you so anyway

Just tested. The sound is the same both ways (very noticeable and much better than before), and the atmos logo still appear when you play content having selected the homepods from the ATV control center, wich wasnt the case before the update (ie the Irishman on Netflix, or Apple TV+ content).
 
  • Like
Reactions: Itinj24

B/D

macrumors 65816
Mar 30, 2016
1,224
893
This is not correct. You do have to set the HomePods as the default speaker. Turning it off and selecting it from the Control Center you don’t get the Atmos sound. This is very noticeable.

And, well, Apple tells you so anyway

Besides, currently having them selected as default speakers kills my wifi speeds and make the homepods crack and pop. I am not the only one to suffer this. @Makaus, for example, suffers the exact same issue, which make this option inviable for us.
 
  • Like
Reactions: Itinj24

Itinj24

Contributor
Original poster
Nov 8, 2017
3,194
1,574
New York
Thanks for the detailed responses. There wasn’t much on this topic on the internet yesterday. Just a lot of articles on the announcement of it. Was expecting to see an option in the ATV settings like you do with video format.
 

bwfc0907

macrumors regular
Sep 27, 2008
236
9
Bolton, UK
So if i set the HomePod as the default audio this disables my TV speakers all together?

The sound is great on the HomePod but where is it recommended that the HomePod should be placed for the best sound, behind you, next to the TV, etc?

How do I know which movies will be using the HomePod for Atmos?

Sorry for the questions.
 
  • Like
Reactions: B/D

B/D

macrumors 65816
Mar 30, 2016
1,224
893
So if i set the HomePod as the default audio this disables my TV speakers all together?

The sound is great on the HomePod but where is it recommended that the HomePod should be placed for the best sound, behind you, next to the TV, etc?

How do I know which movies will be using the HomePod for Atmos?

Sorry for the questions.

First question: Yes. It disables your TV speakers for the Apple TV HDMI input of your TV set.

Second question: It depends wether you have one homepods or a stereo pair. Straight from Apple mouth:


For the best surround sound, place HomePod within 10 inches of a wall and as close to the center of your TV as possible. If you use a HomePod stereo pair, place the speakers about 4 feet apart on either side of the TV.

Third question. You will see an Atmos badge on compatible content, when you are using the homepods as output for the apple tv, such as this:


atmosscenario3_small.jpg
 

Itinj24

Contributor
Original poster
Nov 8, 2017
3,194
1,574
New York
So if i set the HomePod as the default audio this disables my TV speakers all together?

The sound is great on the HomePod but where is it recommended that the HomePod should be placed for the best sound, behind you, next to the TV, etc?

How do I know which movies will be using the HomePod for Atmos?

Sorry for the questions.
Yeah I couldn’t enable to TV speakers at the same time. I liked having both going sometimes.
 

hobspain

macrumors regular
Mar 29, 2010
127
116
Just tested. The sound is the same both ways (very noticeable and much better than before), and the atmos logo still appear when you play content having selected the homepods from the ATV control center, wich wasnt the case before the update (ie the Irishman on Netflix, or Apple TV+ content).

Not my experience. Can you try Okja in Netflix, at the 7:35 mark. The sound of the streams of water sound so much different in the two scenarios we are discussing.
Also: where do you see the Atmos logo when you are playing content?
 

hobspain

macrumors regular
Mar 29, 2010
127
116
First question: Yes. It disables your TV speakers for the Apple TV HDMI input of your TV set.

Second question: It depends wether you have one homepods or a stereo pair. Straight from Apple mouth:


For the best surround sound, place HomePod within 10 inches of a wall and as close to the center of your TV as possible. If you use a HomePod stereo pair, place the speakers about 4 feet apart on either side of the TV.

Third question. You will see an Atmos badge on compatible content, when you are using the homepods as output for the apple tv, such as this:


atmosscenario3_small.jpg
Regarding the screenshot, that’s only the formats that the content is capable of, not that you can experience it if you don’t have the right gear. For example I get 4K , HDR and Dolby Vision for Greyhound but my TV is only 1080p and doesn’t have even HDR.
 

B/D

macrumors 65816
Mar 30, 2016
1,224
893
Not my experience. Can you try Okja in Netflix, at the 7:35 mark. The sound of the streams of water sound so much different in the two scenarios we are discussing.
Also: where do you see the Atmos logo when you are playing content?

For example in Apple TV+ content like Greyhound like or See, or in Batman Returns (purchased movie from Itunes in 4K with Atmos). Try to swap down on the Siri Remote when you are playing the content to bring audio and subtitles menu up and you should see the Dolby Atmos logo.


For the record: I WANT to use my homepods as the default speakers of my apple tv, but in doing so, several anoying things occur.

A). The Wifi on my Apple TV 4K goes from a robust 300/300 rate to a painfully slow 1-2mb, making streaming of high quality content impossible.


B). The Homepods makes very loud and scary craclking and popping noises when navigating for the Apple TV UI.


C). I cant no longer use Siri in the homepods for apple music without them turning on the Apple tv to play music, which i find very inconvenient.
 
Last edited:

B/D

macrumors 65816
Mar 30, 2016
1,224
893
Regarding the screenshot, that’s only the formats that the content is capable of, not that you can experience it if you don’t have the right gear. For example I get 4K , HDR and Dolby Vision for Greyhound but my TV is only 1080p and doesn’t have even HDR.


Regarding the screenshot, that’s only the formats that the content is capable of, not that you can experience it if you don’t have the right gear. For example I get 4K , HDR and Dolby Vision for Greyhound but my TV is only 1080p and doesn’t have even HDR.


But the Atmos logo didn´t appear to me in the movies card information before 14.1 in Netflix and Apple TV+ when i had the homepods selected as the apple tv output, and now it does.
 

B/D

macrumors 65816
Mar 30, 2016
1,224
893
Regarding the screenshot, that’s only the formats that the content is capable of, not that you can experience it if you don’t have the right gear. For example I get 4K , HDR and Dolby Vision for Greyhound but my TV is only 1080p and doesn’t have even HDR.
Yes and no.



Flatpanelshd explains it better:


It's a little strange that the Atmos menu disappears after selecting HomePod as the default speaker. However, as mentioned in the table, Atmos is enabled, but only for some apps (try Apple TV+ shows):

- "Make sure that Video and Audio -> Audio Format is set to 'Auto'. The Atmos option, which is visible when Apple TV 4K is connected to a compatible TV, will apparently disappear when connected to HomePod. You are still getting the Atmos soundtrack though. This can be confirmed by bringing pressing 'menu' on the Apple remote while watching an Apple TV+ show."

We managed to confirm this with 3 set-ups:

1) Apple TV 4K outputting (HDMI) to Atmos-compatible TV
2) Apple TV 4K outputting (HDMI) to Atmos-incompatible TV
3) Apple TV 4K outputting (AirPlay wireless) to HomePod (after updates)

As you can see in the pictures below, the Atmos label in the Apple TV app disappears in scenario 2. It appears in scenario 1 and 3.

Scenario 1:
https://www.flatpanelshd.co...
Scenario 2:
https://www.flatpanelshd.co...
Scenario 3:

https://www.flatpanelshd.co...

The Atmos logo also appears for me (with 14.2), if I just select the homepods from the control center, without making them the default speakers of the ATV. That wasnt the case before 14.2
 

cardfan

macrumors 68040
Mar 23, 2012
3,563
4,512
To sum it all up it’s a very bad experience. Apple should’ve bought sonos already.
 

B/D

macrumors 65816
Mar 30, 2016
1,224
893
Ok, confirmed. You don´t even need the homepods set up as the default speakers for the apple tv for the home theatre processing to work with 5.1,7.1 and Dolby Atmos tracks.

Final, updated guide, with the help of apple support:

A). Update the Apple TV and the Homepods to the final public released version of 14.2 (betas wont work).

B) Make sure that the Apple TV and the homepods are in the same room in the home app. While you are there, go to the Homepods settings in the Home app and make sure that the "Sound Check" option is off (this affects the dynamic range and volume of everything played through the homepods, and is not recommended)

C). In the Apple TV, go to settings Audio/Video menu and make sure that the "change format" option is off, and that the audio format is set to "Auto". While you are there, turn off "reduce loud sounds" as well (this affects the dynamic range of everything played through the apple tv, and is not recommended).

D). Select the Homepods from the control center of the Apple TV. Then go, for example, to Netflix, and start playing Hubbie Halloween or the Irishman (again, for example). While playing, swap down on the Siri remote to bring up the audio and subtitles menu . You should see the Dolby Atmos logo there (in the info tab), which indicates that your are indeed playing a dolby atmos track.

Same with Apple TV+ and Itunes purchases.

Unfortunately, the Atmos logo doesn´t appear on Disney+ streams, only a 5.1 badge, which tells me that the app need to be updated to work with the Homepods . However, the Home Theatre processing of plain old 5.1 tracks by the Homepod is also very impressive.

Turn up your Homepods volume and enjoy!
 

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
Updated my HomePods and Apple TV’s today. Don’t see an option anywhere to enable this, unless I missed something. Help, anyone?

There isn’t anything to enable. It is automatic depending on the audio encoding of the source video. All you have to do is set a single HomePod or stereo pair as the default audio output for the ATV.

Go to Setting > Audio and Video > Default Audio Output and select the HomePods.
 
  • Like
Reactions: Itinj24

B/D

macrumors 65816
Mar 30, 2016
1,224
893
There isn’t anything to enable. It is automatic depending on the audio encoding of the source video. All you have to do is set a single HomePod or stereo pair as the default audio output for the ATV.

Go to Setting > Audio and Video > Default Audio Output and select the HomePods.

Even this isn´t necessary (see my post above).
 
  • Like
Reactions: Itinj24

Macguy31

macrumors newbie
Jan 12, 2015
28
5
I’m having some trouble, at least I think so. I’ve updated my HomePod and AppleTV 4K, both are in my Home app under Living Room. Under settings in AppleTV, under video and audio I have it set as the following:
Audio Output - Living Room (AirPlay)
( my HomePod is named living room )
Audio Format is set to Auto
Audio Mode is set to Auto.

That should be it, right? Nothing says Atmos anywhere. The only new thing I can get is if I change the audio format to “on” and then it lets me select Dolby Digital 5.1 under new format. I’ve tried that but something tells me this isn’t what I should be using.
I’ve looked up an AppleTV + episode that does have Dolby Atmos but when I play it and press menu, there is no badge for Dolby Atmos - I only see the badge on the preview page not when I actually play it.
I was not able to find how to make the HomePod the default speaker for AppleTV in the home app either - there was no option for that so I just changed it in the Apple TV settings. I’m also using a Samsung QLED TV if

Also, unrelated but when I have my HomePod set up as the speaker to use, just using it for music now turns on my AppleTV which I definitely don’t want. If I’m just using the HomePod for music, I’d prey my TV to stay off.

So how far off am I from getting the most out of this new feature?
 

mallbritton

macrumors 6502a
Nov 26, 2006
940
254
@Macguy31 leave the Audio Format and Audio Mode set to auto. You will not see any badges or any other indication that Atmos or 5.1, etc is being used. It is all automatic.
 
  • Like
Reactions: Macguy31
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.