HomeKit Homekit Automation not working when I'm away

karansaraf

macrumors regular
Original poster
Jul 18, 2010
201
0
I've got an ATV 4K as my Homekit hub and a few blinds, Philips Hue lights etc. in my setup. Nothing too special.

The automations I've set as standard to happen everyday (blinds opening and closing), certain lights to come on and off work absolutely fine.

However I've got three Philips Hue lights that I want to come on and off at certain times only when I'm not in the house. I've set this up in the Automation bit correctly (Light 1, comes on 15 mins after sunset, only when I'm away; Light 1, turns off at midnight, irrespective of whether I'm at home or away; similar things for lights 2 and 3, with varying times of coming on and off)

Yet whenever I'm away it doesn't seem to turn these lights on, I have to do it manually.

Any ideas? Can't see anything about specifying that "me" equals my iPhone, which I would have assumed it as standard, so not sure what else I could do?
 

LiveM

macrumors 65816
Oct 30, 2015
1,152
543
The two most likely issues are:

1) You have it set to turn off (the default) instead of on, or;
2) You have not set your home address, or allowed access your location, or some other location issue such as not connecting to the same Wi-Fi network.
 
Comment

karansaraf

macrumors regular
Original poster
Jul 18, 2010
201
0
Thanks for the reply.

1. So the settings are fine - they come on at one time, and go off at another.
2. You're right I wasn't sharing my location - this has now been turned on. How do I set my home address? Can't find a place in the Home app. Wifi settings are all ok as all other homekit accessories and remote control work fine.
 
Comment

LiveM

macrumors 65816
Oct 30, 2015
1,152
543
I would do it in the Contacts app for a start. In Maps, you can also do it but I think it just accesses the Contacts app when you want to set it.

You also need to make sure you are signed into iCloud on all relevant devices and I think you also need Keychain on, and to turn on Home in your iCloud settings.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.