Home HomeKit automation suddenly stopped working in Apple's Home app

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by striders, Jan 12, 2017.

  1. striders macrumors 6502

    Joined:
    Mar 11, 2009
    #1
    I have multiple HomeKit compatible devices (Philips Hue, ecobee, Koogek, iHome) and they all work just fine with Apple Home app.
    All the devices show up in the Home app and I don't have to use the individual devices app. I also have AppleTV 4th generation.

    I setup 2 simple automation with the Home app:
    - Turn off devices at 11:00 PM
    - Turn on devices at 8:00 AM

    Works well for months. Suddenly as of 2 days ago, the automation no longer works. The setup is still in the Home app but no longer activated at the scheduled time.

    I tried:
    - removing and re-adding the automation in Home App
    - checking to make sure I can control each devices in the Home App
    - rebooting AppleTV

    No dice.

    Anyone experienced the same issue?
     
  2. sirgromit macrumors member

    Joined:
    Sep 25, 2009
    #2
    I've experienced this issue and determined that it was caused by being locked out of my Apple ID. This was extremely frustrating as Apple does not notify a user when their account becomes locked or even why it has become locked. Upon unlocking the account, automations resumed working.

    I would highly recommend that the Apple ID used with HomeKit be tied to a unique email address that is not known/used anywhere else to hopefully eliminate the chances of being locked out of your Apple ID. I would guess that the most common reason for this is a random internet user trying to guess your Apple ID password.
     
  3. jmomls macrumors newbie

    jmomls

    Joined:
    Jan 12, 2017
    #3
    I had a similar issue. Homekit disappeared from ATV and Home app on iPhone was blank. I tried the steps you took and then some. Turns out un-pairing the device [thermostat] from the network and re-pairing it solved it. About five minutes after re-pairing Homekit automagically reappeared in ATV settings and Home app on phone started working again.
     
  4. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #4
    Hmm.. that's interesting. So unpairing the thermostat (ecobee) from HomeKit fix the issue with automation with other devices (not ecobee)?
     
  5. jmomls macrumors newbie

    jmomls

    Joined:
    Jan 12, 2017
    #5
    No, but I don't have any other devices. It did fix the issue of the ATV / iPhone not being able to see/control any of these devices. Maybe it would work for this case?
     
  6. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #6
    Yeah, I may give this a shot.

    Right now the Apple Home app can see/control all my devices. It's just the automation part no longer work in the Home app.
     

Share This Page