HomeKit HomeKit/CarPlay/Garage Door

bbednarz

macrumors 65816
Original poster
Nov 16, 2017
1,315
3,283
Chicago
Probably one of the more strange questions so I don't really expect anyone to know the answer, but maybe you'll have some troubleshooting ideas besides wiping my home and starting over...

So for awhile I had the Insignia garage door opener that works with HomeKit. I seemed to always have issues with it and I think one day the battery in the sensor died and I never even bother to change it because it caused more headaches than it was worth. Couple of nights ago I am looking at the homebridge reddit page and one thread was talking about garage door openers through homebridge. Someone mentioned iSmartGate (which is HomeKit certified) and he raved about how reliable it was yada yada... I looked it up on Amazon and they had it for $110 (kinda on the pricier side, but I wanted something that was going to just work. So I grabbed it and in the last few days it has been rock solid.

Now to CarPlay...When the Insignia would work and I was driving, CarPlay would put an icon on my screen to open/close the garage door. I go to leave my house and the icon pops up for the old opener. I had already removed it from HomeKit a day or 2 earlier. The new opener is the only garage door opener in my home. Is there some kind of way to 'refresh' so the home data pushes the new opener through? Would you think this would classify as a CarPlay issue or a HomeKit issue?
 

bbednarz

macrumors 65816
Original poster
Nov 16, 2017
1,315
3,283
Chicago
Yeah, I did most of the standard troubleshooting. Last night when I left the house it still was showing my old opener. When I left for work this morning it showed the new one. Looks like it figured itself out.
 
  • Like
Reactions: Itinj24
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.