HomeKit HomeKit has gone stupid...

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by BF1M, Apr 8, 2019.

  1. BF1M macrumors newbie

    Joined:
    Nov 17, 2018
    #1
    This is a little long winded so bear with me.

    Literally overnight my HomeKit devices have stopped acting correctly. Everything was working perfect for better part of a year. I made no changes or added no devices; this literally started just coming home from work.

    So in the various rooms I have lights set up basically as such..

    Example: Office

    HomeKit Name: Office Lights(group of the two bulbs in the fixture)
    Turned on: The overhead lights

    HomeKit Name: Office Lamp
    Turned on: The lamp on my desk.

    That's generally how I have the rooms set up for Office, living room, our bedroom etc. Up until this...event...I was able to get Siri to turn on the over head lights, the lamps, an individual lamp(based on it's inviduvial name), all the lights in the room etc.

    Basically, again without changing anything, Siri has stopped understanding the difference between the word lamp and light...... but only in certain rooms. When I tell it to turn on X Room lamps it turns on every bulb in the room etc.

    HomeKit has always needed a lot of hand holding but now it's just being stupid. Even if I give the device some arbitrary name it still won't control the device separately. It sees it all in one room, see it's a light and turns it on no matter if I use the word lamp or light.

    Furthermore, it only does this for certain room types. I have no control over the lights in the living room or bedroom but my office ones still work correctly.


    Not sure if that all made sense but does anyone have any idea how to proceed? As a stop gap I had to move every single device to one master "room" in the home app, name them all what they are, then go from there. This allows me to control them individually but robs me of room and zone control.

    Thanks
    --- Post Merged, Apr 8, 2019 ---
    I meant to post this in the HomeKit section, I apologize.
     
  2. nelson1457 macrumors member

    Joined:
    Sep 25, 2013
    #2
    Yeah, I was having troubles with HomePad refusing to set a timer. Everything else seemed fine. I reset the device, it worked.

    But . . . then some songs wouldn't play from my iTunes Match subscription. This went on for a good fourteen hours. Then, after *another* reset, that problem fixed itself.

    Just plain weird . . . I wonder if something isn't going on in the cloud?
     
  3. bbednarz macrumors 6502a

    bbednarz

    Joined:
    Nov 16, 2017
    Location:
    Chicago
    #3
    A little over a week ago I was having some weird HomeKit issues too. I am not sure if something was going on with the cloud or something. My scene for when I leave the house was making the lights all blue instead of the normal white. Have you tried re-creating the room?
     
  4. ipedro macrumors 601

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #4
    Yeah, same here.

    Unlike most Apple devices, HomePod is experienced almost entirely through Siri. Updates happen in the cloud, rather than in firmware changes on the device, and those updates are in my experience happening virtually every day, sometimes multiple times a day. So if something has changed, they’re likely tinkering with it in Siri’s labs. The timer problem went away after a day or two.
     
  5. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #5
    I read your post and I thought I wrote it. I have the same setup and HAD the same trouble. If I said the device then the room it works fine, very odd. ex. Turn on the lamp in the office. Sometimes if I say turn on the office lamp it will turn on both lights or tell me I can't activate the office or some nonsense I don't listen too...
     
  6. BF1M thread starter macrumors newbie

    Joined:
    Nov 17, 2018
    #6
    It’s still not working the way it was. Apple told me they updated things to allow for more options so now you have to name things more specifically. So instead of living room lamps, end table lamps etc

    Whatever.
     

Share This Page

5 April 8, 2019