Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

TRICKorDEVICE

macrumors 6502a
Original poster
Sep 20, 2014
828
112
I'm having a consistent issue since iOS 10. It seems that after about a day or if I leave the house I have to restart my iPhone in order to have HomeKit working properly. For instance if I don't restart my iPhone I can't control devices through Siri, and I can't see the status of my thermostat through the Home app or in the control center.
Is anyone else having this problem?

Is this an iOS 10 bug? Any suggestions on fixes?
 
  • Like
Reactions: luckydcxx

xraydoc

macrumors demi-god
Oct 9, 2005
8,866
3,254
192.168.1.1
I'm having a consistent issue since iOS 10. It seems that after about a day or if I leave the house I have to restart my iPhone in order to have HomeKit working properly. For instance if I don't restart my iPhone I can't control devices through Siri, and I can't see the status of my thermostat through the Home app or in the control center.
Is anyone else having this problem?

Is this an iOS 10 bug? Any suggestions on fixes?
Yeah, similar issues with lights not being reachable. Still some bugs to work out.
 

3587

macrumors 6502a
Mar 23, 2008
747
87
I've been able to turn Airplane Mode on/off and it will connect to HomeKit again. Very frustrating, as I have some automations set to times... They often won't trigger unless I do the Airplane toggle. Annoying.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.