Home Homekit on tvOS10 ?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by friedmud, Sep 13, 2016.

  1. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #1
    I thought we were going to be able to control Homekit stuff with our AppleTV's now? I just updated my tvOS to 10... and no dice. No "Home" App... no Siri control of Homekit devices.

    What gives?
     
  2. Solver, Sep 13, 2016
    Last edited: Sep 14, 2016

    Solver macrumors 6502a

    Joined:
    Jan 6, 2004
    Location:
    Cupertino, CA
    #2
    Go to the iCloud Accounts section. Make sure it shows the correct account. Click it and it should show "Homekit connected." If it does not, sign out, restart the Apple TV then sign back in. Also try toggling iCloud "Home" setting on a working homekit (iPhone/iPad/iPod Touch) device off (count to 10) and back on. That final step got it working for me.
    Now I can ask Siri on Apple TV 4, "What is the temperature in the master bedroom?"
     
  3. jimmcginnis macrumors newbie

    Joined:
    Feb 6, 2012
    #3
    Thanks! That worked!
     
  4. ButteryScrollin macrumors 6502a

    Joined:
    Jul 29, 2014
    #4
    so under iCloud, I should see something other than just photos?
    Tried logging out, restarting, toggling Home on and off.
     
  5. RaNdOm macrumors regular

    RaNdOm

    Joined:
    Jan 9, 2003
    Location:
    Albuquerque, New Mexico
    #5
    I'm having the same problem.
    Accounts
    iCloud
    Only shows photo options
    Logged out
    Restarted Appletv
    Logged back in
    Still nothing.
     
  6. treyvonnk macrumors newbie

    Joined:
    Oct 21, 2015
    #6
    This worked for me too, thanks a bunch!! Also, another tip is to be patient after turning off Home in iCloud on your iPhone/iPad... After turning off the toggle (you might also need to navigate away from iCloud), it will prompt you and say that you need Home enabled to use iCloud or something... then agree and voila!
     
  7. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #7
    You need to check your iCloud settings on a different device like an iPhone, scroll down a little and it will be in there. Once enabled on the other device it should become available on the AppleTV.
     
  8. Jay-Jacob macrumors member

    Jay-Jacob

    Joined:
    Sep 10, 2015
    Location:
    England
    #8
    Is home app suppose appear apple TV or not? I have HomeKit connect on Apple TV setting fine. I cant remember if Apple TV have home app?
     
  9. sjtidy macrumors member

    Joined:
    Oct 29, 2011
    #9
    There isn't a Home app, it's just Siri. Mine took a few restarts and signing in and out of iCloud to get the HomeKit setting to show up, but it's all working now.

    You also need to have two-factor login enabled for your iCloud account.
     
  10. Jay-Jacob macrumors member

    Jay-Jacob

    Joined:
    Sep 10, 2015
    Location:
    England
    #10
    Thanks. Couldn't remember. Look like that no use to me because can't use Siri.
     
  11. philMBP, Sep 15, 2016
    Last edited: Sep 15, 2016
  12. chrisandersen macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #12
    The log out/restart doesn't work here either. I have two 4th Gens, and neither will show. I have also turned off home from all of the iPhones and iPads. Why does it have to be so difficult, Apple?
     
  13. pdmpolishing macrumors member

    Joined:
    Sep 18, 2007
    #13
    I had to setup two factor authentication on iCloud for homekit to work on Apple TV
     
  14. Coffee50 macrumors 6502

    Joined:
    Apr 23, 2015
    #14
    How do you set up 2 factor authentication?

    I don't see the HomeKit option on my Apple TV either. It's set up on my iPhone & iPad.
     
  15. ButteryScrollin macrumors 6502a

    Joined:
    Jul 29, 2014
    #15
  16. ECJ macrumors 6502

    ECJ

    Joined:
    Jul 5, 2006
    Location:
    Memphis, TN
    #16
    I had the same issue, and I had 2FA turned on. I restarted the AppleTV, logged out of icloud, logged back in and restarted again. Then it finally showed connected. I think I crossed my fingers too.
     

Share This Page