Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

HomePod HomePod disappears from AirPlay

teejaysyke

macrumors regular
Original poster
Aug 5, 2012
164
44
I bought a HomePod back in late February. Set up was a breeze but I happened to notice that it would show up under the AirPlay device list for like a day or two and then completely disappear. The only way I could get it to show back up in the lists on my Macbook Pro and iPhone X was to unplug it and replug it back in.

I contacted Apple about it and they replaced the unit and this new unit is showing signs of that happening too.

Has anyone figured out why it does this? If so, what is the solution? We reset it, changed who could access the speaker and more. I'm not quite sure what to do and I'm only trying a few more things before I make Apple take it back and refund me because this is annoying.
 

afir93

macrumors 6502a
Jan 5, 2018
730
908
I had that happen aswell sometimes but not as often. Have you tried dis- and reenabling WiFi or temporarily putting your affected Mac/iOS device where it won't appear into Airplane mode? That usually made it show up for me afterwards again on that device. Other times the issue also resolved itself and the HomePod was visible again a few minutes later when I checked back.

Not sure if there's a permanent fix for it.
 

teejaysyke

macrumors regular
Original poster
Aug 5, 2012
164
44
I have reconnected wifi and much more. I just want it to be there all the time. I hope a future update addresses this because it's turning me off on the speaker a lot. The HomePod sounds amazing as hell, but to have to unplug it and replug it back in every few days to get it to show up on my devices doesn't seem like a big issue but after awhile it gets annoying.
 

lazypoet

macrumors regular
Jun 9, 2015
212
44
I changed the wifi settings on my router from a double secure WPAWPA2-PSK (TKIP/AES) to a WPA2-PSK (AES) connection. This permanently fixed the issue for me, Homepod is now showing up instantly as airplay device on Appel TV
[doublepost=1530955686][/doublepost]
I changed the wifi settings on my router from a double secure WPAWPA2-PSK (TKIP/AES) to a WPA2-PSK (AES) connection. This permanently fixed the issue for me, Homepod is now showing up instantly as airplay device on Appel TV
I also enabled Airplay 2 setting on Apple TV by approaching my phone to the Apple TV. I hadn't done this before? Don't know if it had an impact.
 

kschles

macrumors regular
Apr 3, 2008
242
31
You say you reconnected WiFi, but I’m not sure what that means. I had the same problem. Rebooting my router, fixed the issue, and it hasn’t reappeared in several months.
 

teejaysyke

macrumors regular
Original poster
Aug 5, 2012
164
44
I've reset the network a few times. Just by restarting the router and stuff. Not sure if I need to do more.
 

kschles

macrumors regular
Apr 3, 2008
242
31
I've reset the network a few times. Just by restarting the router and stuff. Not sure if I need to do more.

On my router (Verizon FIOS Quantum), there is a reset button on the back (you need a pen or paper clip to access the small hole to press it). Holding the button for 15 seconds returns the router to factory settings. A Verizon tech told me that this is different from unplugging and then plugging the router.
 

gio1s

macrumors newbie
Jun 13, 2011
5
1
I bought a HomePod back in late February. Set up was a breeze but I happened to notice that it would show up under the AirPlay device list for like a day or two and then completely disappear. The only way I could get it to show back up in the lists on my Macbook Pro and iPhone X was to unplug it and replug it back in.

I contacted Apple about it and they replaced the unit and this new unit is showing signs of that happening too.

Has anyone figured out why it does this? If so, what is the solution? We reset it, changed who could access the speaker and more. I'm not quite sure what to do and I'm only trying a few more things before I make Apple take it back and refund me because this is annoying.
 

lazypoet

macrumors regular
Jun 9, 2015
212
44
I think I have an idea why this has been giving me trouble for so long. Today again my homepods didn't show up as airplay units.

So I went once more to my wifi router settings, and I discovered that I have two wifis - 2,4 and 5 GhZ. The 2,4 was set to 20 MhZ and the 5 was set to 40 MhZ. I read online that the 40 MhZ setting might interfere with other wifi signals. So I changed the 5 to 20 MhZ, and the homepods popped up on my airplay list directly afterwards.

Can the people having trouble check these settings?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.