HomePod HomePod not showing up in AirPlay

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by spencecb, May 7, 2019.

  1. spencecb macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #1
    Has anyone been having issues with their HomePod disappearing from their AirPlay menus across Mac OS and iOS? This started happening to me just a few days ago.

    The HomePod is connected to the internet, which I can verify by using Siri to play music, answer questions, etc. I only have one WiFi network in my home.

    All of my software across every single device is up to date. On Sunday morning, for example, I was streaming a podcast to my HomePod from my iPhone, but when I came back from running an errand my HomePod would no longer show up. But, it does show up in the Home app. I reset my HomePod and set it up again, and after about an hour it started showing up in AirPlay menus, but then stopped showing up later that day and I haven’t been able to get it to show up again since.

    Any thoughts or similar experience?
     
  2. spencecb thread starter macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #2
    No one else is having this issue?

    I ended up taking it to the Genius Bar and they said the hardware checked out so it is likely a software issue.

    Well, I just updated everything to iOS 12.3 and it is still not showing up in AirPlay on anything.

    Very annoying!!
     
  3. Solver, May 14, 2019
    Last edited: May 14, 2019

    Solver macrumors 6502a

    Joined:
    Jan 6, 2004
    Location:
    USA
    #3
    Did you restart your Wi-Fi router?
    Are some Wi-Fi devices on 2.4Ghz and others on 5Ghz?
    Have you tried using any fixed IP addresses?
     
  4. spencecb thread starter macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #4
    I hadn’t tried that until just now, but I just restarted my WiFi access point, and that has seemed to fixed the problem, but I’m not going to get my hopes up yet. Reason being is each time I have unpaired my HomePod and restored it to factory settings it would show up in AirPlay for about 20 minutes then it would disappear and never come back.

    I’ll report back again in a couple hours to let you know if it is still working or not.
     
  5. spencecb thread starter macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #5
    And after approximately 24 hours the HomePod is nowhere to be seen in any AirPlay menu again. This is super annoying.
     

Share This Page

4 May 7, 2019