HomePod HomePod won't Play Podcasts

jas07

macrumors regular
Original poster
Oct 13, 2011
189
50
Hi Guys,

Im really pulling my hair out with this one, even though im subscribed to Apple Podcasts and they play perfectly on all other devices, when I ask Siri on the HomePod to "Play my Podcast" she says that im not subscribed to any podcasts.

Anyone got any suggestions? Ive got personal requests enabled and ive tried factory resetting and setting up again but still get the same issue.

Any help appreciated!
 
  • Like
Reactions: Twitchly

jas07

macrumors regular
Original poster
Oct 13, 2011
189
50
Yeh tried rebooting and factory resetting but still the same result
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,063
9,246
Detroit
On your iPhone, in Settings, Podcasts, is Sync Podcasts enabled? If so, try disabling it for a bit and then re-enabling it. Maybe reboot the iPhone too and the HomePod again.
 

jas07

macrumors regular
Original poster
Oct 13, 2011
189
50
It was enabled on iPhone and iPad, disabled / reenabled and rebooted both but still nothing :(
 

mgirg

macrumors regular
Mar 19, 2008
106
18
Hi Guys,

Im really pulling my hair out with this one, even though im subscribed to Apple Podcasts and they play perfectly on all other devices, when I ask Siri on the HomePod to "Play my Podcast" she says that im not subscribed to any podcasts.

Anyone got any suggestions? Ive got personal requests enabled and ive tried factory resetting and setting up again but still get the same issue.

Any help appreciated!
I am having exactly the same issue. It won’t play my podcast stations either, Siri just says it has encountered a problem. It worked fine until 11.4. Must be a software bug which will hopefully be resolved in 11.4.1
 

Twitchly

macrumors newbie
Jul 11, 2008
5
0
Hi Guys,

Im really pulling my hair out with this one, even though im subscribed to Apple Podcasts and they play perfectly on all other devices, when I ask Siri on the HomePod to "Play my Podcast" she says that im not subscribed to any podcasts.

Anyone got any suggestions? Ive got personal requests enabled and ive tried factory resetting and setting up again but still get the same issue.

Any help appreciated!
Similar problem here. I’ve got iOS 12.1 installed on my HomePod. If I tell it to “play my most recent podcast,” no problem. But if I tell it to “play podcast X” or “play X podcast,” it says “Playing your podcast X” — and then does nothing.

Works fine on my iPhone (also running 12.1).

Frustrating.
 

Similar threads

  • gw0gvq
2
Replies
2
Views
232
  • Jdizzle188
0
Replies
0
Views
169
  • nelson1457
2
Replies
2
Views
188
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.