HomeShare: AppleTV on different router than computer

Discussion in 'Apple TV and Home Theater' started by musukosan, Nov 25, 2010.

  1. musukosan macrumors regular

    Joined:
    Aug 6, 2008
    #1
    Is there a way to get AppleTV to see my computer if it's on a different router than the AppleTV? I have the ATV connected to my DSL router, but I have a wireless router connected to the DSL router for wireless N capabilities. The iMac, of course, is connected to the wireless. But I assume that is preventing my computer and AppleTV from seeing each other. Is there anything I can do to fix that? (Other than make them share the same router)
     
  2. thetruth1985 macrumors 6502

    Joined:
    Sep 17, 2010
    #2
    I have a similar setup and it does not matter if the router is different. What matters is that they are on the same network. Have you enabled home sharing on your imac?
     
  3. musukosan thread starter macrumors regular

    Joined:
    Aug 6, 2008
    #3
    Yes.
     
  4. musukosan thread starter macrumors regular

    Joined:
    Aug 6, 2008
    #4
    I'm not sure what else to troubleshoot. If I connect the ATV to the wireless router, Homeshare works fine.
     
  5. Evgenyy macrumors regular

    Joined:
    Jun 23, 2010
    #5
    You need to have your router set up on the same subnet as your modem. If your modem IP is 192.168.0.1 then your router should have an IP address in the range 192.168.0.*

    Also, try to set up your router as a client via a standard LAN port for internet and do not use WAN port.
     
  6. musukosan thread starter macrumors regular

    Joined:
    Aug 6, 2008
    #6
    Thanks, I'll give it a try.
     
  7. amro macrumors 6502

    Joined:
    Jul 7, 2008
    #7
    If you do hook up your router to your modem via LAN port instead of WAN port then consider turning DHCP off on you router. That way the modem does all the ip assigning. Verizon FiOS people do this in order to get a decent Wireless-N router.
     
  8. Evgenyy macrumors regular

    Joined:
    Jun 23, 2010
    #8
    Agreed - completely forgot to mention this!
     
  9. Jestered macrumors 6502

    Joined:
    Oct 13, 2005
    Location:
    Austin, Texas
    #9
    You can check that they are both on the same subnet, but if the modem and router are talking to each other that's probably not the problem. As a couple of others have said, you're probably running into a double NAT problem meaning that both the router and modem are set as the DHCP server. Just disable this in one or the other and you should be fine.
     
  10. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #10
    It sounds to me like you are probably creating a 2nd network with a 2nd DHCP server. You only want one.

    If you have an Apple Airport Extreme router (or Time Capsule)... then I believe that you will want to set "connection sharing" to "off (bridge mode)".

    If you have a non-apple wireless router, find the option to turn of DHCP and let your DSL router be the only DHCP server.

    /Jim
     
  11. musukosan thread starter macrumors regular

    Joined:
    Aug 6, 2008
    #11
    Switching to a LAN port on the Wireless and disabling DHCP did the trick... thanks everyone!
     

Share This Page