hopefully a simple question about MIDI connections

Discussion in 'Digital Audio' started by uncleMonty, Sep 5, 2014.

  1. uncleMonty macrumors regular

    Joined:
    Jun 8, 2012
    #1
    Hi, I am trying a very simple setup on a laptop (MacBook Air running 10.7). I have installed the softsynth ZynAddSubFX (the newest release has brought back OSX support) and connected it to the system audio output using Jack Audio. I can control the synth from the laptop keyboard, and I hear it fine through my monitors, via an Apogee Duet audio interface.

    The problem is in connecting via midi. My external keyboard that I want to use to control the softsynth is routed through an Mbox2. In OSX's AudioMidi setup, I can see the Mbox2 as an available midi device, but I cannot see ZynAddSubFX to connect it. In the MIDI tab of Jack Audio's "connections" window, I can see ZynAddSubFX as a writable client, but the Mbox 2 (nor anything else) doesn't appear in the "readable clients" pane. So I have no way to connect the two.

    Could anyone help me to troubleshoot this? My external keyboard is connected to the Mbox2 correctly but there are no indicator lights when I press the keys--should there be? It's been a long time since I used that unit.
     
  2. fastlanephil macrumors 6502a

    fastlanephil

    Joined:
    Nov 17, 2007
    #2
    Maybe you need up to date drivers for your device that doesn't show up.
     
  3. uncleMonty thread starter macrumors regular

    Joined:
    Jun 8, 2012
    #3
    Thanks for the advice - I should have mentioned that I did that before posting. And the Mbox 2 shows up in OSX's Audio/MIDI setup page, just not in the Jack Audio app qjackctl. I either need to get it to show up there, or I need to get the softsynth to show up in the OSX Audio/MIDI setup page, so I can connect the two.
     

Share This Page