Horrible battery life while sleeping with Mojave

Discussion in 'macOS Mojave (10.14)' started by !!!, Nov 21, 2018.

  1. !!! macrumors 6502

    Joined:
    Aug 5, 2013
    #1
    Hey guys, so I recently updated my 2015 MacBook Pro to Mojave. Previously, I could close the lid and have it sleep for multiple days and, say it was at 50% when I put it to sleep, it would wake up with 40-45%. This morning, I just tried to use my Mac and was unpleasantly woken up to the fact that it would turn on. At all. Not even a no battery icon. I had to plug it in and wait at least 5 minutes before I got it to boot, and when it did it was extremely slow. I just used it yesterday and I know for a fact that it was at least 30% charged. Previously, I could go probably a week of sleeping before it finally ran out.


    What’s also confusing is that within coconut battery, it showed it was completely dead. So I’m guessing my MacBook didn’t shut off when it was sleeping, instead it just ran until the battery died.

    I haven’t installed anything new or done anything else with the MacBook. I don’t have any Bluetooth devices or anything. Have any of you experienced this and is there a fix? I don’t exactly have time to charge my MacBook every morning before I can use it.
     
  2. Dobbs2 macrumors 6502

    Joined:
    Jun 5, 2008
    #2
    My 2014 MacBook Pro only has 161 cycles on the battery. Before Mojave I only had 99 cycles. It stays plugged in a lot to a monitor, but now if its off the charger and asleep I lose about 40% of the battery over night. Since Mojave just using Brave for 30 minutes to web browse it drops about 45-47% of the battery.

    I'm probably going to downgrade at this point as its not worth it.
     
  3. DPapadopoulos macrumors newbie

    DPapadopoulos

    Joined:
    Jul 7, 2018
    Location:
    Russia
    #3
    Use MacPilot software to enable "Standby delay" [​IMG]
     
  4. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #4
    Sleep is totally broken in Mojave. High Sierra was bad but Mojave had a few too many and went all in.
    You can force it to hibernate and I think you lose Find My Mac.

    I just shut it down and don't bother with sleep if I'm away from my charger for an extended period. That way at least Find My Mac will work when it's turned on again (hopefully).

    EDIT: It is worth going through all the settings anyway, there are things you can optimize. The Bluetooth Wake options, enable Do Not Disturb, disable Power Nap. Those won't fix the issue but they might mitigate it somewhat.
     
  5. 0009827 Suspended

    Joined:
    Jul 15, 2018
    #5
    Issue is caused by 3 hour default until sleep turns to hibernate. I changed this setting to 30 mins and now battery behaves normally. (something in standard sleep is causing too much drain).....
    sudo pmset -b standbydelay 1800
     
  6. dazz87 macrumors 65816

    dazz87

    Joined:
    Sep 24, 2007
    #6
    Noticed that too. Standby time is just trash now on Mojave.. Its sooo bad now im turning off my notebook instead of putting it on standby.
     
  7. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #7
    I did a clean install of Mojave and somehow mine was set for 24 hours. Craziness.
     
  8. inkhorn macrumors member

    inkhorn

    Joined:
    Oct 8, 2009
    #8
    My MBP on Mojave 10.14.3 has a standbydelaylow? of 3 hours and standbydelayhigh? of 24 hours by default.

    Code:
    bash-3.2$ pmset -g | grep standby
     standby              1
     standbydelaylow      10800
     standbydelayhigh     86400
     highstandbythreshold 50
     
  9. TGM85 macrumors member

    TGM85

    Joined:
    Aug 29, 2005
    #9
    I had this issue as well. I solved it by enabling deep sleep (hibernate mode 25) and lowering the standby time to 3 minutes.

    You can do this by running the following terminal commands:

    Code:
    sudo pmset -a hibernatemode 25
    sudo pmset -a standby 1
    sudo pmset -a standbydelaylow 180
    sudo pmset -a standbydelayhigh 180
    Battery drain overnight has gone down to (almost) zero. Wake time from sleep is a bit longer though (about 5 seconds more in my case), so there is a small trade off there.
     
  10. Apple_Glen_UK macrumors regular

    Apple_Glen_UK

    Joined:
    Oct 26, 2015
    Location:
    West Sussex, England
    #10
    Has this issue been resolved in 10.14.4? It certainly appears much better for me now. I left my MacBook Pro sleeping for several hours yesterday and it only lost 1% whereas before it was losing 5% or so in just an hour.
     

Share This Page

9 November 21, 2018