Hosting Multiple Websites on 10.6 Server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by dantiston, Apr 11, 2011.

  1. dantiston macrumors newbie

    May 18, 2010

    I'm sure I'm duplicating another thread, but I can't find an explanation here or on's support forum!

    I'm a novice server admin running a server at a church, which we use primarily for web hosting and file sharing. We have our main website hosted on the server... which works well. It's super easy to update the website with iweb -- and super easy for everyone else who's not so into computers.

    I'm trying to bring that same ease to updating our Children's Center website with iWeb and hosting it on the server. It's currently hosted on GoDaddy's web hosting, which has awful customization settings. I'm trying to switch us from GoDaddy's hosting to web hosting on the mac.

    So far, by changing GoDaddy's DNS info to point to our dyndns host, I can get our GoDaddy domain to point to the server.... but it loads the church's website! I have set up a new Web Site in Server Admin with the Web Folder pointing to the output of iWeb (just as the church's website is set up). I have also tried two different DNS setups from browsing the interwebs (all morning), neither of which work.

    1) I've set up (childrenscenter).org as a Primary Zone with a Web Service running underneath. The web service points to the Machine ID of the church's Primary Zone, which points to the address of the server. (which, I understand, should point it to the web service, which would point it to the right folder, but no! Argh)

    2) I read elsewhere to set up my second site as an alias under my Primary Zone... so I tried that, simply pointing (childrenscenter).org to (, which, also, should point to the Machine ID, to the address of the server, to the children's center website!

    What am I doing wrong? I’m thinking my DNS is set up right… but I guess I don’t know how to set up the web services properly. Ideally, I’d like to keep any tinkering within Server Admin, as I can teach a dedicated volunteer to do that easier than using a terminal command or editing some obscure file.

    Thanks in advanced. :)
  2. Darwin macrumors 65816


    Jun 2, 2003
    round the corner
    Quick question, are you working on the server from inside or outside the network where it resides?
  3. dantiston thread starter macrumors newbie

    May 18, 2010
    The server is behind our primary router and on our primary network. I sometimes use another computer on the same network, and sometimes use the server's own GUI to do tasks. Typically when I need to change something on the server from outside the network, I'll use screen sharing rather than remote server admin.
  4. mikelewis macrumors newbie

    Apr 12, 2011
    Can you post what your website setup looks like in Server Admin? (See attached)

    If you can enter in your browser and get the church website, then your DNS setup seems to be working okay but your web server setup isn't

    Attached Files:

  5. dantiston thread starter macrumors newbie

    May 18, 2010
    Admin Setup

    Here's a screenshot. I'm eager to learn how this might be setup wrong, as I'm bewildered as to the problem.

    Attached Files:

  6. dantiston thread starter macrumors newbie

    May 18, 2010
  7. dantiston thread starter macrumors newbie

    May 18, 2010

    I figured it out. I did have everything figured out -- but when I was first setting up the server, I set up our test domain, (church).net to a catchall -- in server admin there was an alias set to *

    I deleted the alias, set GoDaddy (which I highly despise) to point to our server, and Ta Da! Works fine.

    Moral of the story. Don't use catchalls.
  8. serendipitytech macrumors newbie

    Jul 24, 2011
    Similar issue

    This is exactly what I'm trying to do as well. I just purchased Lion server and it's running, but I can't setup additional websites with different domain names.

    With the Wiki Server on and the Web Server on, going to my domain only brings up the default Wiki home page.

    I don't see a catchall option anywhere though, I'm looking in the Server app under the Web service and also in the Server Tools app under DNS, but nothing with an * or anything that looks like catchall that I can find.

    Any thoughts?
  9. RafaelT macrumors 65816


    Jun 9, 2010
    Lakeland, FL

    Seems to be a bug or poorly implemented feature of the server, there is your answer, I had the same problem, that fixed it.

Share This Page