Hotspot Shield does not work with Snow Leopard

Discussion in 'Mac Apps and Mac App Store' started by fitzpayne, May 22, 2010.

  1. fitzpayne macrumors newbie

    Joined:
    Sep 30, 2004
    #1
    I always used Hotspot Shield to watch American TV shows on the internet from Canada as it blocks my IP address. Ever since installing Snow Leopard Hotspot Shield freezes my internet whenever I try to connect with it.

    I have tried uninstalling reinstalling getting rid of preferences and updating, to no avail. Any suggestions as to how to fix or another application that works in a similar fashion.
     
  2. ayzee macrumors 6502a

    ayzee

    Joined:
    Jun 12, 2008
    #2
    Would trying a different browser like firefox help?
     
  3. Ardoptres macrumors regular

    Joined:
    Dec 12, 2009
  4. fitzpayne thread starter macrumors newbie

    Joined:
    Sep 30, 2004
    #4
    Oddly enough, I found out today that, it does not work on the wireless at my house, but when I took the laptop to my friend's house it worked just fine on their wireless!
     
  5. TheNewDude macrumors 6502a

    Joined:
    Mar 17, 2010
    #5
    I gave it a try today too. It wasn't not effective at doing what i downloaded it for. I wan't able to watch anything on Hulu unfortunately...

    Anyone else have any solutions?
     
  6. Sara213 macrumors newbie

    Sara213

    Joined:
    Jul 29, 2008
    Location:
    Canada
    #6
    Yes I have noticed the same thing.

    It freezes my Internet connection when ever i tried to access a website. I shall give it a try on a wired connection when i come back to canada. Then all the wireless connections shut down on me...so i have to reboot my macbook.

    In the meantime...there is a website where you can watch all the tv shows you want.

    www.watch-series.com

    Not too bad website. But open it in firefox because in Safari you will get alot of pop-ups (the only thing i hate about that site)
     
  7. awoolman macrumors newbie

    Joined:
    May 22, 2011
    #7
    I think that you will find that the problem is with your Firewall. Go to the System Preferences, click on Security, select Firewall and then click Stop. Hotspot Shield should work now. If you restart the Firewall it should ask you if you want to accept openvpn (or something similar) incoming connections. Accept. There shouldn't be any more problems.
    Clicking on Advanced and adding Hotspot Shield to the list may also work, though I haven't tried it myself.
     

Share This Page