How annoying is iTunes with albums - can anyone help?

Discussion in 'Mac Apps and Mac App Store' started by horrgakx, Dec 5, 2007.

  1. horrgakx macrumors member

    horrgakx

    Joined:
    Dec 5, 2007
    Location:
    UK, North West
    #1
    Hi - I'm new to iTunes after buying an iPhone.

    I'm trying to upload music to the iPhone but the organisation is completely beyond logic. I've added some screenshots below to demonstrate what the issue is. Can anyone help please?

    I have this option ticked;
    [​IMG]

    Ok, all the songs are listed under the same album...
    [​IMG]

    Why do I have a graphic thinggiemebob for each track?
    [​IMG]

    See how it is grouping them?
    [​IMG]

    All I want to do is have an album name for ALL my music, and if I click it then it opens the tracks. Why does iTunes have to be so obtuse?
     
  2. sammich macrumors 601

    sammich

    Joined:
    Sep 26, 2006
    Location:
    Sarcasmville.
    #2
    Just clearing up some things first: those 'graphic thingys' is the album art for albums/songs which don't currently have any album art.

    Right, I don't know how that 'Group Compilations when browsing' option actually works, but when using that view in iTunes it always groups by album name AND artist. So a new album starts when the artist is different from the one before.

    The solution is simple. Just select the whole compilation, get the info for all of them, then enter something relevant into the 'Album Artist' field.
     
  3. horrgakx thread starter macrumors member

    horrgakx

    Joined:
    Dec 5, 2007
    Location:
    UK, North West
    #3
    Ok that hasn't worked, I have the same entry in the fields "Artist", "Album Artist" and "Album". However on the phone if I go to "Albums" it lists the names of the individual 100 tracks.
    Oh, and I altered the "info" on all 100 songs a few times to try & get it working and each and every time it updated the files to the iPhone by *copying* them across again. AAAH FFS! :mad:

    [EDIT] Tried with another album, same thing, under the iPhone iPod "Albums" category all the individual track names are listed, NOT the album names - and I've manually set it in the "info" on iTunes...


    My next issue is that I want to delete ALL the songs from the iPhone (like the 100 I've just put on). I thought that by deleting all of the songs in iTunes and then syncing then it would happen. However nothing is deleted from the iPhone. Whats wrong here? Can I delete the tracks from the iPhone manually?


    Thanks.
     
  4. horrgakx thread starter macrumors member

    horrgakx

    Joined:
    Dec 5, 2007
    Location:
    UK, North West
    #4
    Here's another major gripe I've got with it - notice in the File Manager view the tracks are all ordered 1-14 by filename. This is then easy to drag them in order into WinAmp and save a playlist for that album.

    However, in iTunes it doesn't know what order they are to be played in and plays them in alphabetical, not song order.

    [​IMG]
     
  5. sreedy macrumors 6502a

    Joined:
    Feb 24, 2005
    Location:
    Somerset
    #5
    Problem1:

    Not sure why that's happening to you, I tried to re-create the issues you have but I always get what I'd expect (see attached). I have ticked the same options as you and am ordering by Album like you..... strange.

    [Sorry this doesn't help you much] - What version of iTunes is it?

    EDIT: Maybe change to list view, select all the files, right click and select get info and type the Album name again to insure they are defo exactly the same.

    Problem2:
    Add track # to the view and order by that rather than the Artist which you are currently sorting by.

    To add columns to the view right click on an existing column heading.
     

    Attached Files:

  6. semicharmed macrumors regular

    Joined:
    Jul 24, 2005
    Location:
    New Orleans
    #6
    For compilations, specifically, ignore the Album Artist field in the information. It doesn't matter if the Artist is different as long as the compilation box is checked in the song info. Then when Group Compilations is checked, it should correctly group the albums, showing the album name & "various artists" underneath the album artwork.
     
  7. samh004 macrumors 68020

    samh004

    Joined:
    Mar 1, 2004
    Location:
    Australia
    #7
    Your first issue is to do with two different things. "Group compilations when browsing" removes tracks that have been set as part of a compilation from the artists pane when browsing and sorts them by album instead. Cover Flow is not considered browsing.

    To browse, click the button that looks like an eye in the bottom right next to the eject key. You'll see "compilations" at the top of the artist heading.

    To stop tracks from being segmented like you have shown you have to mess around with the info a little bit, most times it's due to one song, usually the first one to be on it's own (in your case Immortal Beloved) having something different in one of the fields of the get info window. You could make sure they all have the same maximum track number, or they are all disc 1 of 1. You could even set the album artist to various artists and that might do the trick. Of course you also have to make sure the album name is exactly the same for every track, and you can't sort by artist if your tracks are all done by different people. Sort by album, works perfectly for me (and every so often I do have to have a play with it).

    As for your second question, more or less like above, make sure that not only are all your tracks numbered 1 through 14 in "get info" but that they are "1 of 14", "2 of 14", "3 of 14", etc... you could also select them all and choose disc 1 of 1.
     
  8. gsetser macrumors newbie

    Joined:
    Apr 11, 2010
    #8
    Grouping all chapters in a book

    Problem: These are not appearing as ONE book, but by individual chapter. I've tried the following.

    - I selected all chapters
    - Opened 'info' box and re-typed the 'album' and author name so all would be exactly the same.
    - selected 'compilation' and used the dropdown to say 'yes' in the info box.

    Looked in preferences/advanced (as instructed in mac itunes help) for a 'arrange as compilation' check box. It doesn't exist. Looked in all the tabs. No luck.

    I'm at a loss in making this one book appear as one book in the overall organization and flow.:(
     

Share This Page