How can I add language packs?

Discussion in 'macOS' started by SebZen, Jul 4, 2009.

  1. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #1
    I imported a few Russian Music CDs to iTunes and sadly a couple of them have garbled text while the others display fine. I know that garbled text happens when the computer doesn't have the language installed.

    I remember a while ago I used Xslimmer and it got rid of some languages among other things. How do I go about reinstalling cyrillic languages?
     
  2. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #2
    Do the Cyrillic languages show in:

    System Preferences -> Languages -> Edit List
     
  3. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #3
    Thanks!

    Cryllic is not there, but Russian is there and checked. No idea how come they don't display right, in that case. But I guess there's nothing I can do about it.

    At least now I know what to do incase I do need another language :)
     
  4. Signal-11 macrumors 65816

    Signal-11

    Joined:
    Mar 23, 2008
    Location:
    2nd Star to the Right
    #4
    Sounds like you're missing fonts or one of the language subsets/character encoding subsets. What does your Language folder show?

    And do you have Russian checked for iTunes?
     
  5. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #5
    How do I check the language folder? The language menu in system preferences shows about 20, I really don't want to manually type them all out.

    How do I check it in iTunes? I don't see any language options in preferences
     
  6. YASA macrumors newbie

    Joined:
    Jul 21, 2010
    #6
    I have same problem on my new MacBook Pro 13. Did you solve this problem? If yes, how?
    Thanks.
     

Share This Page