Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

CitrusLuna

macrumors newbie
Original poster
Sep 21, 2022
9
7
Tokushima-ken, Japan
Screenshot 2023-02-20 at 23.05.58.png


Please, somebody help me. I already search about this information for a week.

Apple logo -> (option key) System Information... -> Software -> Language & Region.

In this window, the Country Code of System Settings is KR. (Maybe, Korea?)

But I have no idea why this setting is set by Korea.

I want to change this settings to JP(Japan), but I can't change this in my System Settings. (System Settings -> General -> Language & Region -> Region is aleady Japan. Preferred Languages is English (Primary) and Japanese only.)


Is there has any solution to solve this problems?

And also, I want to delete Korean assets in 'Requested Linguistic Assets' in User Settings.

Please, somebody help me.

p.s. I already set 'Apply to Login Window' by Japanese.

Screenshot 2023-02-20 at 23.13.49.png
 

CitrusLuna

macrumors newbie
Original poster
Sep 21, 2022
9
7
Tokushima-ken, Japan
It might be just another Ventura bug. Try to change Region to US, verify that it has been changed, then change it again to Japan.
Apple's support article "Change Language & Region settings on Mac" https://support.apple.com/guide/mac-help/change-language-region-settings-on-mac-intl163/mac
Screenshot 2023-02-20 at 11.27.53 PM.png


Okay, I tried it.

And my Country Code of 'User Settings' was changed, but Country Code of System Settings is still KR.

There's any solution to change System Settings? Like terminal commend or something...
 

CitrusLuna

macrumors newbie
Original poster
Sep 21, 2022
9
7
Tokushima-ken, Japan
Okay... I think I found a solution of one thing.
The Requested Linguistic Assets of User Setting is can be erase below.

~/Library/Preferences/.GlobalPreferences.plist

Open this file with Xcode, and go to follow key.

NSLinguisticDataAssetsRequest
- Item String ko

Select this section, and delete it and save it.

This affects to Requested Linguistic Assets of User Setting.

But I still have no idea to change System Setting. (Not user settings.)

Screenshot 2023-02-20 at 11.41.11 PM.png
 

bogdanw

macrumors 603
Mar 10, 2009
5,835
2,832
From Terminal
Code:
sudo defaults write /Library/Preferences/.GlobalPreferences.plist Country JP
 

CitrusLuna

macrumors newbie
Original poster
Sep 21, 2022
9
7
Tokushima-ken, Japan
Oh my. I solved it myself.

The problem is on exactly same file, but about system library.

Disk(default is 'Macintosh HD') /Library/Preferences/.GlobalPreferences.plist

this file is the problem.

Screenshot 2023-02-20 at 11.45.58 PM.png


I copied this file to my another directory (because Xcode can't edit system files directly)
And just edit Root > Country String to 'JP'.

And I tried to copy to original directory, And, boom!

Screenshot 2023-02-20 at 11.48.27 PM.png


It's solved.

I didn't expect that after spending a week worrying about this problem and bringing it up this forum, I would be able to solve the problem myself in a few minutes.

Oh my god.
 

Attachments

  • Screenshot 2023-02-20 at 11.45.58 PM.png
    Screenshot 2023-02-20 at 11.45.58 PM.png
    740.8 KB · Views: 106

CitrusLuna

macrumors newbie
Original poster
Sep 21, 2022
9
7
Tokushima-ken, Japan
From Terminal
Code:
sudo defaults write /Library/Preferences/.GlobalPreferences.plist Country JP
Oh... I didn't notice I can overwrite it with terminal.

BTW, where is the place to storage 'OS Interface Languages' of System Settings? My Mac has lots of languages on this option, so I want to delete what I don't use...
 

bogdanw

macrumors 603
Mar 10, 2009
5,835
2,832
  • Like
Reactions: CitrusLuna

BadMacRumours

macrumors member
Mar 17, 2022
84
175
Toronto, Ontario
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.