How can I change the mount options for a drive?

Discussion in 'Mac Basics and Help' started by gunhorde, Sep 18, 2006.

  1. gunhorde macrumors newbie

    Sep 18, 2006
    Upper Midwest
    I've got an external Lacie firewire drive and I need to change the mount options for my users. The current default settings for mounting it are:

    /dev/disk2s4 /Volumes/Data (local, nodev, nosuid, journaled)

    I need to remove the 'nosuid' flag from the drive to allow user and group permissions to be altered by my end users.

    Any assistance would be greatly appreciated


    UPDATE - The drive is in Mac OS X format, not native UNIX. Is this a problem for what I want to accomplish?
  2. robbieduncan Moderator emeritus


    Jul 24, 2002
    You will need to drop down the command line and use the mount command to mount it normally. A quick "man mount" should reveal how to set the options...
  3. gunhorde thread starter macrumors newbie

    Sep 18, 2006
    Upper Midwest
    can I automate that?

    I know how to manually alter it, but I want to make it permanent and automatic. The file '/etc/fstab' exists, but is it used? The current file is empty except for several commented out examples.


    UPDATE - The manual option doesn't work for some reason, I get the error "Incorrect super block" when I use the mount command.

    from the command line, 'mount' shows the following for my device:

    /dev/disk2s4 on /Volumes/datastore (local, nodev, nosuid, journaled)

    I can unmount the device with umount /Volumes/datastore, it works fine.

    When I attempt to remount the device, I get the error mentioned above. The mount commands I've tried are:

    mount /dev/disk2s4 /Volumes/datastore
    mount -t ufs /dev/disk2s4 /Volumes/datastore
    mount -t ufs -o local,nodev,nosuid,journaled /dev/disk2s4 /Volumes/datastore

    All commands produce the same error message, or a useage message. A reboot remounts the device just fine.

    The command mount -a also has no effect

    I've also created an entry in the blank /etc/fstab file with mount options, it's ignored apparently, there is no change after a reboot; the device is mounted with the original options intact.

Share This Page