How can I disable hyperthreading in 10.9.3?

Discussion in 'OS X Mavericks (10.9)' started by BrockJon, Jun 20, 2014.

  1. BrockJon macrumors newbie

    Joined:
    May 18, 2014
    #1
    Calling All OSX Wizards....

    How can I disable hyperthreading in OSX (10.9.3)? I have Xcode. Went Open Developer Tools > Instruments > Preferences > CPUs > Uncheck Hardware Multi-Threading. From there I've restarted; I've also invoked sleep mode and then woke the computer up. Either way, I'm still seeing 24 processors in Activity Monitor.

    What do I need to do to get it to take?? :confused: And if I end up preferring it, what do I need to do to make the computer keep that preference (after reboots, et al)?

    Thanks!!
     
  2. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #2
    AFAIK, it won't stick. In earlier versions of OSX there were Terminal commands that would "toggle" this. Now, invoking sleep or a restart will reset your setting change.
     
  3. BrockJon thread starter macrumors newbie

    Joined:
    May 18, 2014
    #3
    The thing is I can't even get it to switch at all. Any ideas?
     
  4. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #4
    Install CHUD then run
    Code:
    hwprefs -v cpu_ht=false
     
  5. BrockJon thread starter macrumors newbie

    Joined:
    May 18, 2014
    #5
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    4.6.2 appears to be the newest version, although you may want to try downloading it directly from Apple in case that other site has a broken copy.
     
  7. BrockJon thread starter macrumors newbie

    Joined:
    May 18, 2014
    #7
    Downloaded from Apple's site and got the same error: "The installation failed. The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance."

    This time I was able to open the Processor Pane but I don't think it's working correctly as it's showing "Core Freq: 0 Hz". I unchecked Hyperthreading, invoked Sleep - no change. Same with restarting.
     
  8. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
  9. BrockJon thread starter macrumors newbie

    Joined:
    May 18, 2014
    #9
    How can I disable it on a Mac Pro? Like you, I'm on 5,1 firmware.
     
  10. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #10
    Check /Library/Application Support/HWPrefs/CPUPalette.app
     
  11. BrockJon thread starter macrumors newbie

    Joined:
    May 18, 2014
    #11
    Thank you!

    That's interesting. Following the above Xcode/Instrument process, CPUPalette shows "thread B" disappearing as soon as I uncheck Hardware Multi-Threading. No sleep or restart.

    Does this mean hyperthreading is actually disabled even though Activity Monitor still shows 24 processor windows?

    And if I find the system to run better this way, is there a way to make hyperthreading disabled as the default?

    Side note: CPUPalette can't fit all my processors on the screen. It cuts off at the header of CPU 11. There's no scroll bar or anything. Odd.
     
  12. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #12
    Most likely CPUPalette won't work. I'd try that before. It can't diable any core nor hyperthreading on my 4,1 (flashed 5,1).

    Anyway, if your thread B disappear, you may use GeekBench to stress your CPU and see if the virtual core stay at zero loading in activity monitor.
     

Share This Page