How can I force Mail to use Safari as its web browser?

Discussion in 'macOS' started by AVR2, Jul 21, 2010.

  1. AVR2 macrumors 6502

    Joined:
    Jan 16, 2006
    #1
    Whenever I click on a link in Mail, it opens it in Firefox. How can I force Mail to use Safari instead? I thought there would be a simple way to select a web browser in the Preferences for Mail, but if there is, I can't find it.

    I'm using Mail 3.6 under 10.5.8.
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    Safari->Preferences->General->Default Browser
     
  3. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #3
    Is Firefox set to be your default browser? Mail will open links in your default browser.
     
  4. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #4
    D'oh! :rolleyes:

    Thanks guys. I had no idea Safari wasn't my default browser, because I always launch it manually.
     

Share This Page