How can I get Safari to fill the entire browser window?

Discussion in 'Mac Basics and Help' started by zelduh, Oct 19, 2013.

  1. zelduh macrumors newbie

    Joined:
    May 15, 2011
    Location:
    Los Angeles, California, USA
    #1
    I have a 27" iMac. When I open Firefox or Chrome browser windows, the information displayed fills the entire open browser window. But when I open Safari, there is a HUGE margin (about 3.5") on both sides of the browser window so that images and text are very small. The entire web page is so small that I have to switch to Firefox in order to read.

    Yes, I CAN increase the font size using Apple+, but this does not fill in the unused margins and it does not increase the size of the images. Instead, it makes it very difficult to read because lines will begin to overlap.

    Ideas? What is wrong with Safari? Is there a setting that is wrong?
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Does this issue affect all sites, or just a specific site?
     
  3. zelduh thread starter macrumors newbie

    Joined:
    May 15, 2011
    Location:
    Los Angeles, California, USA
    #3
    It affects all sites, including this one.
     
  4. Scott7975 macrumors 6502

    Joined:
    Oct 18, 2013
    #4
    New to macs so take this with a grain of salt. On PCs you can use CTRL + and CTRL - to increase, or decrease the size. I would imagine on Mac it would be CMD + and CMD - ?

    Im not sure if that would help you but that's all I got.
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    Try this link to activate fluid mode and see whether it makes any difference. That won't help with any other sites though.
     
  6. zelduh thread starter macrumors newbie

    Joined:
    May 15, 2011
    Location:
    Los Angeles, California, USA
    #6
    Well it certainly REDUCED the margins! (Sadly, it did not eliminate them.)

    What is "fluid mode?" P'haps I can use it on other sites somehow?
     
  7. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #7
    Fluid mode is specific to MR. By default, the site is fixed to 1000 pixels wide (I don't know the reasons for this), but fluid mode removes that restriction by setting the width to 100% of the browser size. I can't explain why you're still getting margins after enabling fluid mode, and also can't speak for any other sites.
     
  8. NigelWaring, Aug 12, 2014
    Last edited by a moderator: Aug 12, 2014

    NigelWaring macrumors newbie

    Joined:
    Aug 11, 2014
    Location:
    Sydney, Australia
    #8
    Judging by this and many other forums I think that lots of people have the same problem of Safari not filling the screen. I'll attach images below to demonstrate what I mean. When I open up a window Safari creates quite a small picture that fills less than half of the screen, I can enlarge it to what any other normal browser automatically does with the keys Command, Shift and + but this can become tedious when you are trying to read 20-30 pages. I start the day with online newspapers so 20-30 pages that I open in new tabs is probably a low number for any day, unless I manually enlarge every screen I'd need a magnifying glass to read them. I just want Safari to remember the defaults that I use, just about every other browser that I have does this but having an Apple Computer I'm trying to do the right thing and have an Apple Browser.

    [​IMG]

    Above I'm using my Home Page to demo this problem which applies to every page that I display, they are all too small to be useable.





    [​IMG]


    Seems like I might have found another problem, my above pictures will not display, they do work in other browsers.

    The above is after I have manually corrected the problem, it is far too tedious to do this all day long with all the pages that I view

    I've just come across another problem with the browser. Under menu choices File/Share there is "Email this page", it does just that but without the URL which makes that exercise pointless. When I want to share a website with someone it is pointless doing it if I cannot automatically give them the URL which is what every other Browser does.
     
  9. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #9
    That's because you didn't link to the images but rather to HTML files that show the images. The IMG tag requires an image. I've fixed them up for you :)
     
  10. NigelWaring macrumors newbie

    Joined:
    Aug 11, 2014
    Location:
    Sydney, Australia
  11. wlossw macrumors 6502a

    wlossw

    Joined:
    May 9, 2012
    Location:
    Montreal, Quebec, Canada
    #11
    Have you tried adjusting the zoom? Cmd-+ to zoom in or pinch apart on trackpad cmd-- or pinch together on trackpad to zoom out.... Most web pages are designed for lower resolution screens than your iMac... Which is why you normally get big margins...
     
  12. NigelWaring macrumors newbie

    Joined:
    Aug 11, 2014
    Location:
    Sydney, Australia
    #12
    Thanks wlossw. Yes I have tried the zoom but like I said it is very tedious when you have to do that 20-30 times just to read one on-line newspaper; it would be so much easier if Safari could remember that I want that to be set as a default just like every other browser does. There just does not seem to be any default for this that can be adjusted in Safari. Apple charges high prices so it is not unreasonable to expect a quality versatile product.
     
  13. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #13
    You can set the minimum font size in Safari Preferences/Advanced, in case that helps.

    A.
     
  14. NigelWaring macrumors newbie

    Joined:
    Aug 11, 2014
    Location:
    Sydney, Australia
    #14
    Thanks Alrescha, yes I've tried the minimum font size, it does not make any difference to the size of the picture.
     
  15. wlossw macrumors 6502a

    wlossw

    Joined:
    May 9, 2012
    Location:
    Montreal, Quebec, Canada
    #15
    Well I guess you could simply use another browser, chrome, Firefox and opera should all be options...
     

Share This Page