How can I install Find My Friends on ios 7

Discussion in 'iPhone' started by Stanick, Nov 4, 2014.

  1. Stanick macrumors regular

    Stanick

    Joined:
    Aug 30, 2014
    Location:
    Sofia, Bulgaria
    #1
    It says I need to have ios8 installed but I don't want to upgrade. Anyway I can install an older version?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Nope, Apple over writes the older version with the newer one. If you don't have it saved in your iTunes backup/library then you're out of luck.
     
  3. simmonsj macrumors newbie

    simmonsj

    Joined:
    Aug 24, 2010
    Location:
    Newcastle upon Tyne, UK
    #3
    Actually you can do this. Apologies, I know it's an ages old thread but it still comes up in searches.

    You have to have had the App when it was available in the iOS version you are trying to install to.

    When you try to install it, App Store will say something of the lines that this app requires iOS8 (or 10, currently) BUT it gives you the option to install the older version. I have just put an old version of Find Friends on an iPhone 4 running iOS7 which I'm setting up for my daughter.

    Incidentally I had to go into settings and sign into iTunes & App Store with my own AppleID on which the earlier "purchase" (ok, it was free) of the app had been made. Then after the install go back into settings/iTunes & App Store, and sign back in with my daughter's account.
     

Share This Page