How can I make iMac 5K go to sleep when idle?

Mark200789

macrumors newbie
Original poster
Jun 3, 2015
22
9
I have 2014 iMac 5K that doesn't properly fall asleep when idle. The screen turns off, but nothing else does. Backups continue. External harddrives are constantly being accessed (for what, I have no idea). System sounds play. There doesn't even seem to be a settings option to do it. There is an option to "Prevent Computer from sleeping when display is off" which I have unchecked, but there is no "Put the computer the sleep after this amount of time" option like a laptop. Desktops need energy saving too. If this can't be done in system settings is there an app that will properly sleep the machine after so many minutes? Thanks!
 

Attachments


Moonjumper

macrumors 68000
Jun 20, 2009
1,995
1,547
Lincoln, UK
I'm sure there used to be a setting for the computer going to sleep, but that kind of thing has gone missing, or not being made obvious, in recent years (alongside such things as Clear History in Safari doing much more than clearing history). I have a 2015 iMac and also wish there was a clear option for getting the computer to sleep. I assume you also have "Put hard disks to sleep when possible" checked and "Enable Power Nap" unchecked?
 

galedll

macrumors newbie
Feb 26, 2019
3
0
Well, click on apple logo in uper left corner on the screen and choose sleep.
 

DeltaMac

macrumors G3
Jul 30, 2003
9,526
2,299
Delaware
Or, use the keyboard shortcut:
Press Control-Eject, then press the "S" key.
Goes to sleep now, without any arbitrary delay. I've been using that as my normal "sleep my Mac, then get up and leave" for several years. Always works, and very quickly.
 

Mark200789

macrumors newbie
Original poster
Jun 3, 2015
22
9
assume you also have "Put hard disks to sleep when posusible" checked and "Enable Power Nap" unchecked?
Yup. I included a screen shot of my energy savings panel.

Well, click on apple logo in uper left corner on the screen and choose sleep.
Or, use the keyboard shortcut:
Press Control-Eject, then press the "S" key.
Do you manually turn on your screen saver, too? I know that option is there. I'm asking for an automatic solution based on lack of keyboard input. There's no reason why I should have to sleep the machine by hand every time I walk away from it.
 

ZMacintosh

macrumors 65816
Nov 13, 2008
1,168
277
first try a NVRAM reset: https://support.apple.com/en-us/HT204063

then select restore defaults in energy saver settings and readjust as needed.

you can also select a timed schedule for the iMac to sleep and wake in energy saver settings, by clicking schedule.

make sure the os version is uptodate
 

mikehalloran

macrumors 68000
Oct 14, 2018
1,600
390
The Sillie Con Valley
Energy panel settings vary depending on the OS. Mojave, especially, made changes.

If you restore Defaults, the OS won't matter — all will do what you want.

Resetting the NV RAM doesn't hurt.

If, however, the new settings don't hold, replace that battery. If you have an HDD inside, get a high-heat BR2032 like Apple used. Amazon has the best prices. If SSD only, a common CR2032 is fine. They are electrically identical but the BR2032 has a wider heat tolerance.
 

Mark200789

macrumors newbie
Original poster
Jun 3, 2015
22
9
Energy panel settings vary depending on the OS. Mojave, especially, made changes.

If you restore Defaults, the OS won't matter — all will do what you want.

Resetting the NV RAM doesn't hurt.

If, however, the new settings don't hold, replace that battery. If you have an HDD inside, get a high-heat BR2032 like Apple used. Amazon has the best prices. If SSD only, a common CR2032 is fine. They are electrically identical but the BR2032 has a wider heat tolerance.
I think this worked. I reset both the NVRAM and the SMC. I set the volume to full, let the machine sleep itself, and didn't hear my new mail sound blasting in the middle of the night or in the morning while my phone was buzzing me. So it looks like it's going into full sleep again. Thanks! I've been suffering with this for years and just letting it slide.
 
  • Like
Reactions: mikehalloran

mikehalloran

macrumors 68000
Oct 14, 2018
1,600
390
The Sillie Con Valley
Great. You know the fix if the settings don't hold, 5 years is sooner than most for battery replacement but not unusually so. It's under the screen.

One thing, though. Normally, when pulling the screen, a tech like I will tell you that replacing the ACHI SSD with an inexpensive NVMe 3 x4 (Intel 660p) can give it a nice speed boost — and they're right.

There's a problem, though. The 2013–14 don't wake from sleep properly. No big deal, a simple Terminal command is the workaround but it works by preventing deep sleep. This may not be something that you'd like.

2015-on Macs do not have this issue and the 2013–14 wake from sleep issue cannot be fixed any other way.
 

mikey8811

macrumors member
Mar 23, 2019
79
12
first try a NVRAM reset: https://support.apple.com/en-us/HT204063

then select restore defaults in energy saver settings and readjust as needed.

you can also select a timed schedule for the iMac to sleep and wake in energy saver settings, by clicking schedule.

make sure the os version is uptodate
I have always wondered about the default settings for a desktop Mac vs a Macbook - specifically Prevent Computer From Sleeping When the Display Is Off.

When I leave that unchecked as per the default, any browser downloads I do inevitably fail - but then I use Firefox and not Safari so i don't know if it is because of that. As a result I have always checked this preference.

A friend advised that the setting is more for MacBooks for energy saving purposes rather than desktop Mac's which are plugged in to a power supply all the time.

Does this affect the computer's longevity though?
 

mikehalloran

macrumors 68000
Oct 14, 2018
1,600
390
The Sillie Con Valley
Longevity? Not at all. An SSD based iMac uses less energy than a night light when the display is off unless you have work going on such as a long download. So what if Time Machine backs up every hour (I have 4 Time Capsules for my main iMac so each one runs twice a night)? All of my backup drives are connected via wireless or Ethernet so that sleep cannot be an issue ever.

Yes, deep sleep is to conserve battery life. I don’t enable it on my desktops.