How can I make my graphics card dedicated?

Discussion in 'MacBook Pro' started by Myiphone7, May 9, 2011.

  1. Myiphone7 macrumors 6502a

    Joined:
    Nov 18, 2010
    #1
    I just bought a MacBook Pro. Videos look great but text isn't as good. Instead of the graphics card switching, how can I make it dedicated?
     
  2. altecXP macrumors 65816

    Joined:
    Aug 3, 2009
    #2
    You can use gfxstatus to lock the D card on, but that wouldn't effect text display any, and will just kill your battery life.
     
  3. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #3
    Also if you set the setting to not switch under the display preferences it will default to the dedicated display at all times.
     
  4. Yvan256 macrumors 601

    Joined:
    Jul 5, 2004
    Location:
    Canada
    #4
    Are you a switcher? Maybe you're just used to the way Windows incorrectly does anti-aliasing. ;)

    P.S.: I'm a switcher too... Give it time and soon you'll prefer the correct anti-aliasing of Mac OS X and find the Windows one "too sharp".
     
  5. ZombieZakk macrumors 6502

    Joined:
    Feb 23, 2011
    #5
    settings-> energy saver preferences-> uncheck automatic graphics switching. (this will force the computer to always use the dedicated gpu.)

    also what res screen did you get? did you go to a lower res than your previous computer?
     
  6. tchockey macrumors member

    Joined:
    Feb 9, 2010
    #6
    hi
    if looking to make text better read this below and give it a try.
    Got this from a review on amazon.
    it might help for your macbook pro text.
    hope this helps. lol


    I was surprised that others hadn't mentioned having same problem that I did at first, but then I noticed that the other Mac users were using laptops with this monitor, so they probably had to use the DVI input. I have a 2010 Mac Mini, so it has an HDMI port. At first I used an HDMI to HDMI cable, and the image was slightly larger than the screen, and text was a little fuzzy. You can downsize the image in the display settings, but then text becomes even fuzzier. Using the HDMI to DVI adapter that came with the Mac Mini solved that problem-- almost.

    The next thing you need to do is go to Applications/ Utilities/ and then open the Terminal. Copy this line and then press return:
    defaults -currentHost write -globalDomain AppleFontSmoothing -int 1
    Then restart (or log out) and upon startup the text will be sharper. That's a tip that's been passed around the internet a lot. Apparently in Snow Leopard, Apple changed the font rendering options available in the Appearance settings, so this is a way to get around that and activate the old sub-pixel rendering method (Apple Font smoothing). You can undo the change (if you don't like the results) by checking the box (that will now have a dash) in the Appearances section, which says "Use LCD Font Smoothing When Available." But most people seem to agree that this doesn't work as well as the old method.
     
  7. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #7
    Yup. That's the problem.
     
  8. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #8
    I swich'd about four years ago and I still prefer Windows sharpness.
     

Share This Page