Resolved How can I remove the Previous System folder?

Discussion in 'macOS' started by brunozs, Jan 15, 2017.

  1. brunozs macrumors member

    Joined:
    Sep 7, 2005
    #1
    I've tried everything. Every single stuck trash app. Tried logging in as root. Cant delete Previous System folder for anything!

    Does anyone know how to do it?
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    What do you mean with ‘previous’? Chances are that if you are on El Capitan or Sierra that you cannot delete it as long as System Integrity Protection is enabled. Reboot into Recovery, enter ‘csrutil disable’ in a Terminal window and reboot.
     
  3. brunozs thread starter macrumors member

    Joined:
    Sep 7, 2005
    #3
    That worked out perfectly! Thanks!!
     
  4. Ian James macrumors newbie

    Joined:
    Jan 15, 2012
    Location:
    Atlanta
    #4
    Thanks a lot, worked perfectly for me as well. That was driving me crazy.

     
  5. dickguertin macrumors newbie

    dickguertin

    Joined:
    Sep 4, 2010
    Location:
    Mountain View, CA
    #5
    Don't forget to remove 'Previous System' from any backups. Most likely, you can do that with 'sudo' commands, such as: sudo rm -rf /Volumes/backup.disk/Previous\ System -- because there's no System Integrity Protection on backups.
     

Share This Page

4 January 15, 2017