How can i restore/recover files from Bootcamp with Boot Failure - Missing OS

Discussion in 'Windows, Linux & Others on the Mac' started by blazingriver, Dec 3, 2013.

  1. blazingriver macrumors newbie

    Joined:
    Dec 3, 2013
    #1
    Hi,
    I am having a few problems with bootcamp on my imac. When i tried to move the bootcamp partition on windows 7 into free space, it crashed and turned off. Ever since i have had the error 'Missing operating system' and it fails to boot. I have some very important files on the bootcamp partition. Is it possible to recover these files or even to restore the bootcamp partition to it's original state? I do not have a backup of my bootcamp partition. Another problem i have is that ever since i tried to expand my macintosh HD partition into free space, when i hold alt while booting up (to choose which partition to boot like i normally do), the bootcamp partition has stopped appearing. This means that i cannot even boot the windows 7 bootcamp partition anymore!

    So basically here are my 2 questions:
    How can i restore/recover files from Bootcamp with Boot Failure - Missing operating system error?

    How can i make the Bootcamp partition appear in Startup Disk and when i hold the option key while starting up my computer to allow me to boot windows 7?


    Any solutions are very much apreciated! :)
    Thanks!

    I know that bootcamp (disk0s4) hasn't been fully deleted since it appears in disk utility (i cant do anything to it though)
    [​IMG]
    And here is the error i see when i try to launch bootcamp (back when i was actually able to boot up bootcamp to the error screen)
    [​IMG]
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Your best shot is probably to remove the drive and place in an external caddy or enclosure....USB / FW and see if you can read the files from there.

    Disk Warrior is an app that has helped many here recover lost data too, and that would allow you to leave the drive in place.
     
  3. Quackers, Dec 3, 2013
    Last edited: Dec 3, 2013

    Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #3
    It's not a good idea to try to resize any partition on a Boot Camped drive. The system does not cater for that - one result of which is that the partition table can be damaged.
    Moving a Windows partition is also somewhat hazardous. Windows doesn't like it and the boot process can be upset.
    First I would try booting from your Windows installation disc and go to the command prompt. Once there I would try these entries in this order
    bootrec /fixmbr
    bootrec /fixboot
    bootrec /scanos
    bootrec /rebuildbcd
    On running the last one you should (hopefully) see that a Windows installation is found. If it is found it will ask you whether you want that installation added to your boot menu. Answer Y for yes and reboot.

    It may be that the Windows installation is not found.
    If that is the case you may need to fix the partition table first. There are many posts on here by user murphychris on this subject which have helped many to fix similar problems.
     
  4. blazingriver thread starter macrumors newbie

    Joined:
    Dec 3, 2013
    #4
    Thanks for the help guys. When I try to use bootrec /fixboot it says 'element not found'

    Also it says that it found 0 windows installations found so I will look at murphychris' threads.

    Thanks!
     

Share This Page