How can I set printer paper size in Safari and Preview?

Discussion in 'macOS' started by NaN, Jan 25, 2008.

  1. NaN macrumors newbie

    Joined:
    Jan 24, 2008
    #1
    Printing from Safari and Preview is driving me nuts - to the extent that I've mostly stopped using Safari and have switched to Opera. The problem is printing.

    When I print a page it ALWAYS defaults to US letter size. :mad: My printer is configured for A4 default and my localisation is UK. Most applications work fine but I can find no way of setting the paper size option in Safari and Preview. The only solution that works is to tick the scale page box and then change the paper size - but then the page is printed tiny using only part of the available page.

    Is there any way of getting rid of this US letter size default altogether and forever?

    TIA
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    Solution - click this button
    Picture 2.png
    and then change the option here
    Picture 3.png

    Works for both Safari and Preview
     
  3. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #3
    Also, in System Preferences you can set the default paper size.
     

    Attached Files:

  4. NaN thread starter macrumors newbie

    Joined:
    Jan 24, 2008
    #4
    Thanks but ...

    My system preferences are set for A4 and always have been, and the method you show xUKHCx is not persistent - I have to do it every time for every page I want to print, it always reverts to "other". :-( If I forget to change it I get rubbish out of the printer, wasted paper and wasted time ...

    How do I make A4 persistent, just like I can in other apps - I don't have this problem with Opera.
     
  5. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #5
    Interesting because on my system it is persistent so it appears there is a bug somewhere. There are two work arounds that may work that I know of

    1. Create a custom page size that is the same as A4 and choose that and hope it sticks. to do this select paper size in the second screen shot above and then Manage Custom Sizes
    2. Wait for 10.5.2 and hope it fixes it
    3. Could try following the second half of this macosxhint (don't need to log in as root, you just have to save it to the desktop and the move it back into the right place. It may or may not work I can't check as I don't have the problem, but make backups of any file you are going to change. You could either change the default to iso-a4 or you could remove entries for US letter
     

Share This Page