How change keyboard layout in Lion

Discussion in 'Mac OS X Lion (10.7)' started by lonecrow, Aug 30, 2011.

  1. lonecrow macrumors newbie

    Joined:
    Aug 30, 2011
    #1
    Hello all, something is driving me nuts, but I cannot acces the keyboard shortcut to change my layout from English to French. I have it in my bar at the top, but when I click on French, the second I go to type into a box (in this case in lightroom), it goes back to English.

    So I tried seeking out the corresponding shortcut to change it on the fly, and the only one I found works with pre-spotlight (cmd+space)

    So what the hell now guys? This is getting to me....

    Thanks very much!!
     
  2. ipadavid macrumors newbie

    Joined:
    Sep 3, 2011
    Location:
    NY-Barcelona-London
    #2
    Same here, it is driving me crazy. One way around is to hold the key and accents will appear in the same fashion as they do in a iPhone/ipad. It is a workaround but it slows me down when typing.
     
  3. Nick 214 macrumors member

    Joined:
    Jan 11, 2010
    Location:
    Pittsburgh/Slippery Rock, PA
    #3
    That's odd... I switch between Dvorak and QWERTY with no problem.

    NK
     
  4. openspark Guest

    #4
    The shortcuts for switching keyboard layouts are:

    Ctrl-Option-Command-Space = Select the previous input source
    Option-Command-Space = Select the next source in Input menu

    Note the need to use Option.

    You can find these shortcuts by opening the System Preferences window at the Keyboard pane, and selecting the Keyboard Shortcuts tab. Click on "Keyboard and Text Input" in the left pane, and check the last two items in the right pane.
     
  5. ipadavid macrumors newbie

    Joined:
    Sep 3, 2011
    Location:
    NY-Barcelona-London

Share This Page