How do I access an External HD wirelessly with my router?

Discussion in 'Mac Basics and Help' started by MikeT125, Sep 2, 2009.

  1. MikeT125 macrumors regular

    Joined:
    May 16, 2007
    #1
    I want to have access to an External Hard drive wirelessly. The external HD is wired to my iMac, I have a Linksys WRT54G wireless router. My question is this;

    Can I access the external HD on my iMac with my MacBook through the wireless router? If so, what do I need to do?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    I just connect through the network to the machine with the external HD and make sure it is shared so I can get to it. Whether it's wired or wireless it's the same setup. For direct connection the external HD would need to support that specifically. There's some configuration suggestions in this thread.
     
  3. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #3
    How can I make my iMac a network machine? Is there a way I can just "share" the external HDD or is there something I need to click or set up to share this drive?
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #4
    At least with Leopard you just go to System Preferences > Sharing > Check File Sharing. Then, just add your external drive to the list and do any additional setups you want. Here's a little write-up if you need it.
     
  5. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #5
    Thanks, I am going to give that a try when I get home. The article you posted will be a big help. Thanks!
     
  6. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #6
    Well, the iMac computer shows up as a shared drive in the finder window of the MBP (wirelessly) but it always fails to connect.... It doesn't ask me for a password or anything. What am I missing?
     
  7. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #7
    One thing to try: From Finder, make sure you're in column mode (cmd+3). Select the machine you want to connect to in the sidebar (or choose "All" if it's not listed). When you click on the machine the next column over should present 2 buttons, Connect and Share Screen. Use the Connect button and it should prompt you for a user name and password.
     
  8. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #8
    The connect as button doesn't do anything.... it just clicks and the status says "Connecting..."
     
  9. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #9
    Hmm, another tactic; From Finder > Go > Connect to Sever (or cmd+k). You can connect to your machine via IP address or the machine's name. One place to find it's name is in System Preferences > Sharing, then peek up at the top region. It should be a name that ends in .local. So your connection will look like,

    Code:
    smb://192.168.1.101
    or
    Code:
    smb://machine-name.local
    Then hit the Connect button. This should be doing the same things as you tried before, but maybe it will prompt for password this time.
     
  10. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #10
    When I am on the MBP I can see under "shared" I can see the the iMac and it says macintosh and there is another shared computer which is my name, (the name of the imac). So each computer can see the other, the MBP just cannot see the connected external HD that is on the imac. Under Preferences>sharing on the imac, I have the external HD which is called "Time Machine" showed as Read & Write for the MBP (as far as I can tell). It still isn't working.

    I believe the only problem is ME. I am sure the computers are OK, I just haven't set something up correctly.... What else should I check.

    BTW I tried connecting to the server like you suggested and it would quickly say "failed to connect...
     
  11. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #11
    Alright, I found a good article on this, though it's very long. It reminded me of something I did on my setup, that I believe I had to do to get everything right.

    On the article skip down to the section titled "Sharing with other people." It's a little past half way down. You can read the other parts, but they cover things we've tried. The short version of what to try is to add another account using the "Sharing Only" type for the account (as opposed to administrator or standard account). See the article for more details.
     
  12. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #12
    First I want to say Thank you for all of your help so far, it is MUCH appreciated. I am going to look at the article you have posted and get back to you with my results.
     
  13. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #13
    The two computers seem to be sharing the public folder but not anything else. If I put something in the drop box it will show up on the other computer and visa versa. So it does seem they are connected but just not quite the way I want. Now I am able to transfer files and it looks like I am almost there.

    I need to know how I can share the external HD on the iMac so the MBP lap top can use it for a time machine back up drive. I think I am almost there but I am just missing this one last step. What do I need to do now??
     
  14. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #14
    From the article, did you setup a Sharing Only user? Also, let us know of other settings (like if File Sharing is setup in System Preferences, and if AFP and/or SMB are enabled in the options there) you have setup so we know what possible changes to try.
     
  15. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #15
    I did create a "Sharing only" account and have given Read & Write privileges in desperation to everyone, Guests, and all other accounts thinking that that may be holding it back. I used the AFP for all... since the two machines are both Macs.
     
  16. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #16
    The only further advice I can think to give is to also enable SMB to see if it helps.
     
  17. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #17
    It is finally going and here is what I did. A church friend of mine took a look around and found this line of Apple code

    defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

    Apparently, for wireless backups, Leopard only will recognize "Time Capsule for a wireless backup device. When you enter this line of code in terminal, it allows the system to recognize wireless hard drives other than time capsule. When I entered this, it worked perfectly as long as my iMac was powered up and not to sleep. So far so good. Thanks for all your help and I'll be back for more because this is such a great website. :)
     

Share This Page