How do I block access to computers on school network?

Discussion in 'macOS' started by ivnds, Mar 4, 2008.

  1. ivnds macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #1
    new with leopard is this shared tab on the sidebar, and every time I connect to my schools network, i see several computers on the side. I can browse other peoples files, and even copy them, however, i wouldn't like anyone doing this with my files, since a friend had problems with his mac the other day. He wanted to open word and someone else on the network was using it! After that he put the computer on screensaver, and wouldn't wake! he had to reinstall OSX to make it work. I don't know if this is related but it worries me that i can get some of my work or apps snatched.

    I don't really know how to block access to my files from other computers since leopard seems to automatically share the stuff between everyone, can someone shed some light to the subject.
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Just don't have any form of sharing turned on the the Sharing Preference Pane. I take it most of the systems you are seeing are PCs with guest accounts. No one can get on your computer without a username and password.

    TEG
     
  3. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #3
    No, Leopard doesn't automatically share. It just shows other machines that have sharing turned on.

    As for your friend, I'm assuming he stole Word. What he ran into was not someone using his application, but someone using a copy of Word with the same serial number on his segment of the network. If Word detects someone on the network is already running it with that serial number, it'll refuse to open. Solution: don't steal software.
     
  4. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #4
    AMEN. Same goes for Adobe software, it won't run if it finds another S/N running on the network (or the maximum number of installs for the license).

    TEG
     
  5. ivnds thread starter macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #5
    thanks! i didn't know all that. I have every option on sharing turned off and when i check other macs my computer doesn't show on the network, i just wanted to make sure though, cause his computer didn't show either and he had the word problem, now i know why.


    PS. so the not waking from sleep thing, is that OSX related? i myself have been having sleep problems since 10.5.2 and am worried of my computer not waking and having to reinstall leopard again, i backup every night though.
     
  6. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #6
    If it the computer can't wake up, just simply restart it. As for his problem, it is probabily a permission problem. His problem with Word is because he is using the same serial number as someone else on the network.

    TEG
     
  7. ivnds thread starter macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #7
    besides of the word problem (wich is resolved thanks :) ) he also had this issue with the wake up, pressed the button, but on the restart i would load leopard, it got stuck on the blue screen with the spinning thingy.

    And when i say friend i mean like classmate, not me, i got office very cheaply with the 2008 upgrade deal :D, but i don't want my mac not waking from sleep, it concerns me.
     
  8. mmcxiiad macrumors 6502

    Joined:
    Jul 19, 2002
    #8
    also - make sure you either have itunes & iphoto set to not share your library or require a password. It is possible to have sharing turned off in your system preferences and still share both iphoto and itunes.
     
  9. ivnds thread starter macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #9
    I checked those aswell and turned of everything

    thanks for the tip.
     

Share This Page