How do I bring files and folders back to "Root Level?"

Discussion in 'Mac OS X Lion (10.7)' started by Smittay, Sep 9, 2012.

  1. Smittay macrumors member

    Jul 12, 2008
    Hi Everybody,

    I have a frustrating situation.. Time Machine wouldn't work on my iMac that was dying, so the only thing i could do is use Carbon Copy Cloner (CCC) to back it up. However, I did this wrong.

    With CCC, you are supposed to have created a GUID partition on a bootable external HD and backed up your Mac HD to that, so everything is at the Root Level, ie. /Application /Library /System /Users and all the other folders and invisibles ie. .usr .var .tmp ... then you can boot off this external HD and reinstall your system.

    I did not know any of this, i thought CCC was like Time Machine, so I just made another folder on my External HD that was labeled "CCC Weekly Backup". Its in an exact replica of my HD, it is just not at "Root Level".
    It is on my External HD "Erik 2012 Home" then inside a folder called "CCC Weeky Backup."

    How can I move it, so that it isn't in the folder "CCC Weekly Backup"?? and just inside External HD "Erik 2012 Home" ??

    Every time I do this with CCC, it just keeps putting my files inside that "CCC Weekly Backup" I can't just copy them to the "Erik 2012 Home" cause I don't know how to select the invisibles. Even when I just select my Application Folder and .var .tmp /Library it *always* puts them in a folder "CCC Weekly Backup".

    ANy help would be appreciated. Our daughter was born in July and all her pics and videos are on there cause I started using CCC in June, cause my Time Machine stopped working then. So all of June, July and Aug. are in these CCC Backups I can't restore :(

    Thanks so much, as always you guys are the best here!
  2. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Take a look at this Carbon Copy Cloner: Restoring data from your backup
  3. Smittay thread starter macrumors member

    Jul 12, 2008
    I tried that all last weekend :(

    it won't boot from my Ext HD, because all the system files aren't there at the root level to boot from....

    then i did a clean install of Mac OSX, created a rescue partition on my computer and tried to reinstall from there, after 3.5 hours, it said it worked, but it had a permissions problem that my files belonged to the rescue partition, not me, i tried disk utility and it just wouldn't work at all. i did a variation of this 4 times at 3.5 hours each.

    i contacted mike over at CCC and he says that when you do the clean install of Mac OSX, you have to name the user and password the same as your original backup...and then create the rescue partition out of that on your computer... that didn't work either...

    i have everything i need on my new ext mac hd... it just finished copying,
    (erik 2012 home = my external hd), by the way

    but instead of copying it:

    /volumes/erik 2012 home/Applications (all system files) etc

    it is encapsulated in this

    /volumes/erik 2012 home/CCC Weekly Backup/Applications (all system files) etc

    so it can't boot. how do i move all the system files from 'CCC Weekly Backup' folder to the Root Folder "erik 2012 home" which is my ext hd ??
  4. DewGuy1999 macrumors 68040


    Jan 25, 2009
    I'm sorry to say that I don't have any experience with what you need to do, I've only used bootable clones and they have always worked as expected. I don't have any idea if this will work, but can you use OS X's Migration Assistant to move your backed up files from the external to the internal?
  5. Smittay thread starter macrumors member

    Jul 12, 2008
    i will try man, thanks for your help...

    i just wish there was a way to get those sub folders and invisible up one level to the root folder of the external hard drive... i'd be all set !! :(
  6. DewGuy1999 macrumors 68040


    Jan 25, 2009
    I'm not sure I exactly understand what you're trying to do but if it's seeing the invisible files/folders to move them then this might help, Show hidden files Mac OS X 10.7 Lion and 10.8 Mountain Lion.

Share This Page