How do I change default, "system icons" in El Capitan 10.11?

Zen Desk Pro

macrumors member
Original poster
Aug 18, 2015
62
9
Chicago, Illinois
I just updated to El Capitan 10.11 and I'm already being flustered with issues.


How do I change system icons (mail, messages, finder, launchpad) to the default icons I had prior to the update?

I can no longer go under Applications then Get Info and copy paste my image. It simple won't let me do this for system icons (it will let me do it for non-Apple applications, though).

Anyway I can do this without jeopardizing my system?
 

Dwayne82

macrumors member
May 16, 2015
73
10
Switzerland
I think it has to do with the new System integrity protection in OS X El Capitan. You have to disable it before you're allowed to change system-files. (I didn't test this for this specific case)
Do the following steps: (thanks thadoggfather for this procedure)

1) cmd+R key held when rebooting/powering up to go into recovery mode.
2) utilities->terminal from status bar
3) type "csrutil disable" without quotes, reboot,
4) then modify the icons you want to
4b) do the same thing cmd+r and open Terminal and type "csrutil enable" if you want to re-enable system integrity protection.
 

badbluesman

macrumors newbie
Oct 5, 2015
7
0
California
Speaking of icons in El Capitan...



I am seeing two desktop icon bugs since upgrading to El Capitan:



1. Time Machine drive icon moves from its normal spot to bottom of screen. When dragged back to its place, it shoots down to the bottom of the screen. This also happens to other icons when moved- they shoot down to the bottom of the screen. The only fix I have found is to turn off snap-to-grid in the View menu. TM drive still appears at the bottom of the screen sometimes on startup.



2. Time Machine drive icon is no longer green. I made several efforts to fix this, all to no avail. I deleted the drive from TM preferences and then added it back again. I clicked on get info for the drive and tried to drag the green TM icon to the desktop icon (as one user in the macrumors forum did), to no avail.



I had the same two bugs after upgrading from Mountain Lion to Mavericks (Apple's worst OS in years). I was never able to fix it, even after multiple calls to Apple Care. But When I upgraded to Yosemite, it fixed everything. Now, with my recent upgrade to El Capitan, all the Mavericks bugs are back. I had a clean re-install of Yosemite a few months ago for a battery issue, so there shouldn't be any remnants of Mavericks left.

Any suggestions would be appreciated.


MacBook Pro with Retina display, OS X El Capitan (10.11), October 2012
 

Zen Desk Pro

macrumors member
Original poster
Aug 18, 2015
62
9
Chicago, Illinois
I think it has to do with the new System integrity protection in OS X El Capitan. You have to disable it before you're allowed to change system-files. (I didn't test this for this specific case)
Do the following steps: (thanks thadoggfather for this procedure)

1) cmd+R key held when rebooting/powering up to go into recovery mode.
2) utilities->terminal from status bar
3) type "csrutil disable" without quotes, reboot,
4) then modify the icons you want to
4b) do the same thing cmd+r and open Terminal and type "csrutil enable" if you want to re-enable system integrity protection.
Okay, thanks. I'll give this a try.

So when I disable system integrity, alter icons, then enable it again, my icons won't revert upon enabling?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.