How do I change my default country entry in Contacts from Netherlands?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JMC08, Oct 23, 2011.

  1. JMC08 macrumors regular

    Joined:
    Aug 28, 2011
    #1
    Netherlands is the default country in my contacts list. Whenever I add a new address, I have to search through in order to put in the US. Is there a way that I can change the default country?
     
  2. fitzaer macrumors newbie

    Joined:
    Apr 3, 2010
    #2
    Netherlands default

    I just found this same problem, tried Settings/General/International and other suggestions I found online, nothing worked.
    I called Apple support (1 800 MY IPHON) and we tried a couple of resets.
    Finally tried Restore to New iPhone on iTunes, that worked.
    What happened? Their guess is that the person putting my iPhone into service hit a Netherlands code on the telephone number by mistake. They're are a couple of other Netherlands default problems on the internet, so, if it is a human error, maybe it's a fairly easy one to make.
     
  3. dcwebman macrumors newbie

    Joined:
    Oct 29, 2011
    #3
    You're not the only one. The exact thing happened to me last night at the Apple store. Suddenly this morning I discovered I'm in the Netherlands according to my Apple account. Unfortunately 2nd level Apple support said they couldn't do anything because the people that could fix my account are off on the weekends, and of course had never heard of this problem before which I'm glad to see it's not the very first time. I'll probably have to end up restoring again on Monday from my Friday backup.

    That was the second mistake by the Apple store. The first was my phone was set up without a contract so my previous phone number couldn't be ported or even show up on the account I was switching to (AT&T to Verizon). That took 4 hours of talking to numerous people in person and on the phone to resolve.

    Really wondering about going back to the Apple store for future purchases.
     
  4. dcwebman macrumors newbie

    Joined:
    Oct 29, 2011
    #4
    Got a call back from Apple today. Turns out the simple solution after they fixed my account was to re-activate my phone. Sure feels good to be back in the U.S. He said this apparently is sometimes a problem with Verizon.
     
  5. bluefav macrumors newbie

    Joined:
    Nov 15, 2011
    #5
    I am having same problem with all of my contacts defaulting to Netherlands. It only happened after I installed an update as a response to a message from Apple last night 11.14.2011. It is no very frustrating.
    In addition after the update, when someone calls me, it does not show their name, only their number AND all of my phone numbers are all run together with no spaces or dashes. I think all of this has something to do with the Netherlands format because it is also showing the Zip code before the city name but when I change the country (individually to each contact) to US, then the address appears in US format that I am used to seeing. Grrrr!:confused:
     
  6. AlsoEddy macrumors newbie

    Joined:
    Dec 10, 2011
    #6
    In case anyone is still working on getting this fixed for themselves or future folks looking for a fix, I thought I'd post what it took for me to get it working. None of the other fixes seemed to help me move out of The Netherlands. Worst part for me was this default made stored phone numbers not match for Caller ID. Apple support seemed to have no prior knowledge of the issue. After 3+ hours and 5 "specialists" trying various solutions (most of which were posted here and tried by me previously), what finally worked was turning off "International Assist" in Settings > Phone, then (because this appears to be a Verizon issue) dial *228 to update the phone service choosing option 1. Follow this by calling a second time to *228 and select option 2. Once those updates are finished, power off the phone and start it up again. For me, that fixed the problem and I was able to turn the "International Assist" option back on and it was fine (turning it off may have been an be an extra step, but who knows). I wish they had come up with this before having me do a phone reset, but at least it's working... for now.
     
  7. tenfour79 macrumors newbie

    Joined:
    Jan 12, 2012
    #7
    This solution worked like a charm and saved me a trip to the mac store. THANK YOU.

     
  8. angelique macrumors newbie

    Joined:
    Jan 13, 2012
    Location:
    New York, NY
    #8
    Thank you for the solution! Why Netherlands, I wonder?

    Thank you!! This also worked perfectly for me. What a vexing problem it was. For me this was on a Verizon IPhone 4S.

     
  9. msbane macrumors newbie

    Joined:
    Jan 15, 2012
    #9
    Awesome and easy. Wow! Thank you!!

    This fix worked like charm. Saved me a trip to the Apple Store.
     

Share This Page