How do I disable dual monitors?

mothra1961

macrumors newbie
Original poster
Jul 11, 2007
2
0
San Francisco Bay Area
I used to run dual monitors on my mac, but recently decided to go back to just one. Though I disconnected my secondary monitor months ago, my computer still thinks it's there. My mouse goes off the side of my monitor into the space that used to be the secondary one, and items saved to my desktop sometimes also end up there. Frustrating! Please answer for both OS 10.3.9 and OS 10.4.9.
Many thanks!
:confused:
 

DoFoT9

macrumors P6
Jun 11, 2007
17,530
32
Singapore
uumm havent u restarted ur mac in that time?? i thout it detected the monitors every time u restarted. strange.. hope its ok now
 

mothra1961

macrumors newbie
Original poster
Jul 11, 2007
2
0
San Francisco Bay Area
Still not working

Scarlet, I don't have an option called Detect Displays. When I go to System Preferences -> Displays the three options I have are: Display, Arrangement, and Color. If I select 'Display' the options are: Colors, Refresh Rate, Gather Windows, and Show Displays in Menu Bar.

Also, I have restarted many times since I disconnected my second monitor and my situation hasn't changed. This problem is more of a nuisance than anything else, but it would be nice to solve it...
 

iBlue

macrumors Core
Mar 17, 2005
19,182
15
London, England
Scarlet, I don't have an option called Detect Displays. When I go to System Preferences -> Displays the three options I have are: Display, Arrangement, and Color. If I select 'Display' the options are: Colors, Refresh Rate, Gather Windows, and Show Displays in Menu Bar.

Also, I have restarted many times since I disconnected my second monitor and my situation hasn't changed. This problem is more of a nuisance than anything else, but it would be nice to solve it...
It's in the arrangement tab that you'll find "detect displays". I think that should sort it out.
 

imnothere

macrumors newbie
Nov 22, 2007
1
0
Same problem here

I have the same problem as mothra1961 has (or had).
I cannot find a working way to disable that other monitor. I tried pressing the "detect displays" button several times. Not working. I connected and disconnected other display in the mean time. My MacBook still thinks the old CRT Monitor is connected when it's not. (Another annoying thing about it is that the extended desktop holds files i cannot access, since my monitor is not attached.)

Lately, I upgraded to OS 10.5 Leopard (after having formatted the system volume) assuming that the problem might be solved afterwards. However, it's still there and system profiler even states "yes" next to the monitor's online status. I wish i could simply tick "no" right there...

Now, I wonder if my hardware is somehow damaged or if a simple click in some application or preferences pane could make the system ignore that darn display.

Any ideas how to work this out? Or, mothra1961, have you fixed your issue and could you tell me out here?
 

junglecode

macrumors newbie
Dec 8, 2014
2
0
Well, that probably was not an issue for the posters from 2007....

A.

Addendum: no harm done, we have all done it at least once. :)
I posted because I found/fixed the same issue today on Yosemite. Helping out the next poor sap who stumbles on the original post from a web search (like I did.)