How Do I Do This

Discussion in 'Mac Basics and Help' started by vpasq, Apr 10, 2016.

  1. vpasq macrumors newbie

    Joined:
    Dec 4, 2015
    #1
    A while back I created a "Photograph" folder in Applications and moved all my photo apps (including Photo Booth and Image Capture). However, I have since changed things and moved all the applications out except Photo Booth and Image Capture, since each time I try to move them it gives me an error that says Mac OS apps cannot be modified or deleted. I guess trying to move it constitutes modifying it, but I cannot figure anyway out? I want to put them in regular listing in Applications and remove the folder. Can anyone help?
     
  2. Apple fanboy macrumors P6

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the Lens, UK
    #2
    How did you move them in the first place? Just by dragging them? Should work the same .
     
  3. vpasq thread starter macrumors newbie

    Joined:
    Dec 4, 2015
    #3
    That's the weird part, when I set that folder I did drag and drop them no problem, but now trying to take them out it won't let me.
     
  4. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #4
    Did you upgrade to El Capitan since moving them?
     
  5. vpasq thread starter macrumors newbie

    Joined:
    Dec 4, 2015
    #5
    No they were moved long after upgrading to El Capitan
     
  6. richard2, Apr 11, 2016
    Last edited: Apr 11, 2016

    richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #6
    To modify pre-installed applications on OS X El Capitan and later, you must disable System Integrity Protection (SIP):

    1. Start OS X in recovery mode.
    2. Choose UtilitiesTerminal from the menubar.
    3. Enter the following:

      csrutil disable
    4. Restart your Mac.

    Once you've moved the applications back, you should reenable SIP by entering the following command in recovery mode:

    csrutil enable

    Warning: Don't leave SIP disabled because it'll make OS X significantly more vulnerable to security threats.
     
  7. vpasq thread starter macrumors newbie

    Joined:
    Dec 4, 2015
    #7
    Richard2, Appreciate the suggestion. I tried it, but it still would not let me remove them and gave me the same error. Terminal did confirm the disable so it was no mistake there. (I did re-enable after I tried it). Oh well, the beat goes on!
     
  8. vpasq thread starter macrumors newbie

    Joined:
    Dec 4, 2015
    #8
    Well, I found the culprit (by accident actually). I have noticed a severe slowdown in transferring files to my USB drive attached to my Apple Airport Extreme (latest version). Well today, I needed to put some large (2GB and above) files to that drive in a folder and it said it would take nearly 8 hours, so I ejected the drive from the Extreme, plugged it into my MBP directly and it said it would take about 10 mins and it did. However, I immediately noticed I was not getting any more spinning beachballs today since I detached the drive from the Airport Extreme. So, I have to believe (and I don't know why) that it was causing my problem. Crazy and I have no clue why that would have caused the problem, but it is obviously it did. I miss having my network access to the drive, but oh well, I hate that spinning wheel even more.
     

Share This Page