iPod touch How do I enable IOS downgrading?

Discussion in 'Jailbreaks and iOS Hacks' started by macstatic, Sep 19, 2012.

  1. macstatic macrumors 6502a

    Joined:
    Oct 21, 2005
    #1
    Is there a way to enable the possibility of downgrading IOS (iPod Touch 4g) if needed? After reading all the IOS 6 complaints I'd like to have the option to go back to my current IOS 5.1.1.

    I believe I read somewhere that IOS devices don't allow this but with some special Mac software you can take a "snapshot" of the current setup thus allowing to go back.
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    TinyUmbrella lets you save the "SHSH". Once you have that, you just need the official Apple restore image (IPSW) which can be easily found by using Google.

    Use TinyUmbrella ASAP because Apple will likely stop issuing SHSH for 5.1.1 soon.
     
  3. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #3
    Thanks. That sounds like what I need.

    I tried it and am not quite sure if I did everything right (I got a couple of error messages when TinyUmbrella started), but despite my ignorance it looks like I may be out of luck as the log tells me this:

    APPLE is NOT signing iPod4G 5.1b3 (xxxxxxxx) SHSH requests anymore. All you can do now is select CYDIA and hope that CYDIA has your SHSH saved. If not, there is nothing you can do.

    and

    CYDIA DOES NOT HAVE YOUR SHSH FOR iPod4G 5.0.1 (xxxxxxxxx) THERE IS NO WAY FOR YOU TO GET THEM. SORRY. YOU ARE JUST TOO LATE.

    However, in the "General" section of TinyUmbrella I have 6 entries underneath "Saved SSHSs".
    So does all of this mean I have enabled my iPod to reinstall IOS 5 (or earlier?) in case I do install IOS 6 or am I screwed?
     
  4. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #5
    I didn't understand half of those technical explanations in the above link but concluded that a forthcoming version of Redsnow will allow me to downgrade from IOS 6 to earlier versions of IOS.
    So now that the 5.1.1. "blobs" are no longer downloadable through Apple, should I just go ahead and upgrade to IOS 6 (as Redsnow will allow me to downgrade anyway), or will the unreleased version of Redsnow need my existing version 5 in order to extract something from it?
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    If you didn't save the 5.1.1 hashes, it is too late.
    Without them, no option to restore to 5.1.1 now or in the future
     
  6. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #7
    I don't see anything technical explanation there. I don't even know how to put those words into 'non technical term'.

    All I can say is, no matter what idevices you have; you'll need blobs to downgrade firmware. But depending on which idevices, only some options are available.
     
  7. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Not applicable here but Apple still signs 4.1 for 3GS
    That is the one exception
     

Share This Page