How do I enable ownership of an external drive?

Discussion in 'macOS' started by strausd, Jan 30, 2010.

  1. strausd macrumors 68030

    Joined:
    Jul 11, 2008
    Location:
    Texas
    #1
    Hey, I recently bought a new external drive and am trying to put all my old time machine backups on it. I was on the phone with Apple support for a little bit and they said the best way to do this is to just drag and drop the whole backups folder. When I do that, a little window pops up saying that I do not have ownership of the drive, how do I change that?
     
  2. georgegarrigues macrumors newbie

    Joined:
    Jan 31, 2010
    #2
    Similar thing happened to me. System won't recognize the external hard drive, so I am eagerly awaiting somebody to reply to your message. Here is me eagerly awaiting --> :eek:

    Sincerely, your friend, George
     
  3. tomllama macrumors regular

    Joined:
    Jan 7, 2007
    Location:
    CA
    #3
    You tried selecting the drive and using 'get info' to then change permissions? I usually simply select 'ignore ownership' on external volumes.
     
  4. georgegarrigues macrumors newbie

    Joined:
    Jan 31, 2010
    #4
    At one point I could have done that, but right now the external hard drive is not showing up on the desktop so I can't choose it.

    Me still waiting -->:confused:
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    Any mounted device can also be accessed from the Computer view. To go there, choose Go -> Computer in Finder.
     
  6. pit29 macrumors 6502a

    pit29

    Joined:
    May 23, 2006
    Location:
    The Golden State
    #6
    Or mount it with Disk Utility. And maybe, if you format it using Disk Utility, you're the owner as well? I never had a problem...
     
  7. georgegarrigues macrumors newbie

    Joined:
    Jan 31, 2010
    #7
    Well, I shut off the external drive, went to bed, woke up, turned the drive back on in the morning and it now shows up where it should. It checked OK with Disk Utility. I can't open the iPhoto library stored there, but I guess that is a problem for another thread. I suppose I will have to reinstall iPhoto somehow.

    Thanks for your attention to this.

    Sincerely,

    George
     
  8. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #8
    If you're past the point of no return, fair enough, but if you can erase in Disk Utility that will save you a lot of pain. Not being able to get into the iPhoto libary is consistent with incorrect permissions. If you're not going to connect the drive to a PC, format in Mac OS X case-insensitive. Lots of info on the forums for setting permissions for user documents.
     
  9. georgegarrigues macrumors newbie

    Joined:
    Jan 31, 2010
    #9
    I was able to rescue my iPhoto library by using iPhotoManager.app, a very good program.

    George
     
  10. leslie caplan macrumors newbie

    Joined:
    Mar 31, 2011
    #10
    'get info' to then change permissions didn't work

    Hi - I tried Tomillo's suggestion: You tried selecting the drive and using 'get info' to then change permissions? I usually simply select 'ignore ownership' on external volumes. - but am still getting back up doesn't have ownership enabled. any other suggestions?
     
  11. neorotik macrumors newbie

    Joined:
    Jul 18, 2011
    #11
    Correct way

    Leslie, strausd, etc.

    Open Disk utility, copy the name of the drive - ex: "LeslieMacBackup"
    In Finder search and open terminal.

    In terminal, it may ask for user name and password - enter them.

    Copy and paste this:
    sudo /usr/sbin/vsdbutil -a /Volumes/LeslieMacBackup

    (Change the name from LeslieMacBackup to the actual name of the drive)

    ....it may ask for user name and password - enter them.

    When you go back to disk utility and get info on your disk, it should have changed ownership status. :cool:
     
  12. drknowitall macrumors newbie

    Joined:
    Jul 22, 2012
    #12
    Backup Volume Doesn't Have Ownership Enabled

    I have the same issue. I noticed no one came close even guesses were way out in left field. What I have found that after all of these years with time machine and its' quirks, which when everything is working works, end of the day it's still a hack!!

    I just use CCC, works every time, much faster, works over networks.

    Give you an example, the time machine will not back up to the same sparse disk bundle if you switch from wireless to ethernet. How screwed is that. And if you want to restore from any volume other then Apple's Time Capsule, you have to do it in the command line! How screwed it that. After all of these years.

    Reliable backups are extremely important and invaluable in certain circumstances. I have had to fully recover two Macs in one week. I used CCC.

    Apple just doesn't care, they got your money. Mike Bombich at CCC, gives away a superior solution, free.

    Just fed up with Apple crapy attitude. This could be fixed.
     
  13. mr666 macrumors regular

    Joined:
    Sep 14, 2009
    #13
    See what a side-railing we get trapped in when we reply to a thread highjacker? We start off trying to help "strausd" with permissions, and now we are stuck helping "georgegarrigues" with a drive that doesn't even mount. Totally unrelated to the title issue.

    And don't anyone try to bite me for posting old. This is just the big mess we need to learn to avoid, old or not. We avoid it by replying immediately to the highjacker "georgegarrigues" with "Go post your own question. No highjacking allowed."
     
  14. compilation macrumors newbie

    Joined:
    Dec 28, 2012
    Location:
    Planet Earth. Shire of UK.
    #14
    Had the same, found the 'lock icon' and unlocked the new partition and then unticked the option at the bottom (Can't find it now - had the word 'ownership' i it.)

    After that I could drag/drop the TM folder.

    ----------

    Actually, CCC is now charged for.

    I don't know if it's 'superior' - between the Disk Utility and Time machine I seem to manage to do what I need to.

    That said, I recently upgraded my Mac's HD and - based on various FAQs - used CCC (it's free for 30 days ;) ) to create my HD clone. Have to say it worked flawlessly, but then maybe Disk Utility would have worked too. I just had fewer articles explaining how.

    Personally I love these people who subscribe to the Cult of Mac and then complain when it doesn't seem to do everything the way they'd have it work. I have to assume you all never delivered working software to anyone.
     

Share This Page